SSIS ExtractTarget (Salesforce Marketing Cloud)Source Error

Discussion of issues, suggestions and bugs of Devart SSIS Data Flow Components, our product line for building SSIS-based ETL solutions, performing data access to popular cloud applications and databases.
Post Reply
jdomico
Posts: 4
Joined: Mon 16 Dec 2019 15:02

SSIS ExtractTarget (Salesforce Marketing Cloud)Source Error

Post by jdomico » Mon 16 Dec 2019 15:19

Hello,

We have been testing your product out and it has worked very well except for one item.

I have been able to successfully get all of the needed info for the 3 current clients we have in our SFM Cloud except for the SentEvent data – for some reason it times out or hangs when I try to pull it for all 3, however, I can get it just for just one client when I don't specify the ClientID in the Advanced Setting of the connection.

Here is the error that we are receiving:

[Devart ExactTarget Source [2]] Error: Devart.Data.ExactTarget.ExactTargetException (0x80004005): Error accessing web service. ---> System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond <ip address>

Any ideas what can be done to avoid this?

Shalex
Site Admin
Posts: 8979
Joined: Thu 14 Aug 2008 12:44

Re: SSIS ExtractTarget (Salesforce Marketing Cloud)Source Error

Post by Shalex » Tue 17 Dec 2019 19:42

jdomico wrote:
Mon 16 Dec 2019 15:19
I can get it just for just one client when I don't specify the ClientID in the Advanced Setting of the connection
1. You mean the ClientIDs connection string parameter, don't you? If you want to specify several client IDs, you should separate them with commas and without spaces. Give us an example of your ClientIDs value.

2. Tell us your Authentication Type (UserNamePassword / AppCenterClient / ServerToServer / RefreshToken).

3. If you set Support Extension Objects=False in Connection Manager Editor, does this fix the timeout issue?

4. Try increasing Connection Timeout and Default Command Timeout. Does this help?

jdomico
Posts: 4
Joined: Mon 16 Dec 2019 15:02

Re: SSIS ExtractTarget (Salesforce Marketing Cloud)Source Error

Post by jdomico » Fri 20 Dec 2019 18:20

See answers below

1. You mean the ClientIDs connection string parameter, don't you? If you want to specify several client IDs, you should separate them with commas and without spaces. Give us an example of your ClientIDs value.

Added this to the ClientIDs value under behavior - 100012949,100013738,100036403 and data is never returned after running for an hour - no error is received now - once I remove the ClientIDs data is returned for just ClientID - 100012949 - Again having the ClientID string in the settings works for every other table load I have setup, BounceEvent, ClickEvent, Subscriber etc

2. Tell us your Authentication Type (UserNamePassword / AppCenterClient / ServerToServer / RefreshToken).

UserNamePassword

3. If you set Support Extension Objects=False in Connection Manager Editor, does this fix the timeout issue?

Set to False - data is never returned

4. Try increasing Connection Timeout and Default Command Timeout. Does this help?

Set both values to 600 - data is never returned

Shalex
Site Admin
Posts: 8979
Joined: Thu 14 Aug 2008 12:44

Re: SSIS ExtractTarget (Salesforce Marketing Cloud)Source Error

Post by Shalex » Mon 23 Dec 2019 18:32

We cannot reproduce the issue with our test account.

1. Contact the Salesforce Marketing Cloud Support Team to find out the reason why the API request sent by our components never returns data:

Code: Select all

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:u="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">
  <soap:Header>
    <o:Security soap:mustUnderstand="1" xmlns:o="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd" xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">
      <o:UsernameToken u:Id="_0">
        <o:Username>your_user_name_here</o:Username>
        <o:Password o:Type="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-username-token-profile-1.0#PasswordText">your_password_here</o:Password>
      </o:UsernameToken>
      <wsu:Timestamp wsu:Id="Timestamp-5d178d32-1379-477c-9818-c924ad8009e7">
        <wsu:Created>2019-12-23T17:13:57Z</wsu:Created>
        <wsu:Expires>2019-12-23T18:23:57Z</wsu:Expires>
      </wsu:Timestamp>
    </o:Security>
  </soap:Header>
  <soap:Body xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<RetrieveRequestMsg xmlns="http://exacttarget.com/wsdl/partnerAPI">
  <RetrieveRequest>
    <ObjectType>SentEvent</ObjectType>
    <ClientIDs>
      <ID>100012949</ID>
      <ID>100013738</ID>
      <ID>100036403</ID>
    </ClientIDs>
    <QueryAllAccounts>true</QueryAllAccounts>
    <Properties>SendID</Properties>
    <Properties>SubscriberKey</Properties>
    <Properties>EventDate</Properties>
    <Properties>Client.ID</Properties>
    <Properties>EventType</Properties>
    <Properties>BatchID</Properties>
    <Properties>TriggeredSendDefinitionObjectID</Properties>
    <Properties>ListID</Properties>
    <Properties>PartnerKey</Properties>
    <Properties>SubscriberID</Properties>
  </RetrieveRequest>
</RetrieveRequestMsg>

  </soap:Body>
</soap:Envelope>
2. Could you please register at https://skyvia.com, create the Salesforce Marketing Cloud connection, use this connection in some simple package (e.g.: export package) to reproduce the problem? Then, tell us your account name and package ID so that we can investigate logs to make sure there are no internal errors on our side.

jdomico
Posts: 4
Joined: Mon 16 Dec 2019 15:02

Re: SSIS ExtractTarget (Salesforce Marketing Cloud)Source Error

Post by jdomico » Mon 23 Dec 2019 21:38

Hello - when I try to setup the connection in Skyvia using the OAuth 2.0 I cannot login and logging in via User/Pass I can not find the security token - Can you walk me through how to do this?

Also my 30 day trial has expired is there a way to get that extended? Thanks

Shalex
Site Admin
Posts: 8979
Joined: Thu 14 Aug 2008 12:44

Re: SSIS ExtractTarget (Salesforce Marketing Cloud)Source Error

Post by Shalex » Sat 28 Dec 2019 15:29

when I try to setup the connection in Skyvia using the OAuth 2.0 I cannot login and logging in via User/Pass I can not find the security token - Can you walk me through how to do this?
Looks like you selected CRM > Salesforce instead of Email Marketing > Marketing Cloud. You should create the Marketing Cloud connection.
Also my 30 day trial has expired is there a way to get that extended?
Please contact us via https://www.devart.com/company/contactform.html.

jdomico
Posts: 4
Joined: Mon 16 Dec 2019 15:02

Re: SSIS ExtractTarget (Salesforce Marketing Cloud)Source Error

Post by jdomico » Sat 04 Jan 2020 14:10

Hello any update for this? - I sent my skyvia results to the tell us results link listed below last week - the same issue occured using that interface. Thanks

Shalex
Site Admin
Posts: 8979
Joined: Thu 14 Aug 2008 12:44

Re: SSIS ExtractTarget (Salesforce Marketing Cloud)Source Error

Post by Shalex » Mon 06 Jan 2020 14:56

Please contact the Salesforce Marketing Cloud Support Team and ask them to find out the reason why this API request never returns data with your account (we waited for 21 hours before terminating it):

Code: Select all

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:u="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">
  <soap:Header>
    <o:Security soap:mustUnderstand="1" xmlns:o="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd" xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">
      <o:UsernameToken u:Id="_0">
        <o:Username>your_user_name_here</o:Username>
        <o:Password o:Type="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-username-token-profile-1.0#PasswordText">your_password_here</o:Password>
      </o:UsernameToken>
      <wsu:Timestamp wsu:Id="Timestamp-5d178d32-1379-477c-9818-c924ad8009e7">
        <wsu:Created>2019-12-23T17:13:57Z</wsu:Created>
        <wsu:Expires>2019-12-23T18:23:57Z</wsu:Expires>
      </wsu:Timestamp>
    </o:Security>
  </soap:Header>
  <soap:Body xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<RetrieveRequestMsg xmlns="http://exacttarget.com/wsdl/partnerAPI">
  <RetrieveRequest>
    <ObjectType>SentEvent</ObjectType>
    <ClientIDs>
      <ID>100012949</ID>
      <ID>100013738</ID>
      <ID>100036403</ID>
    </ClientIDs>
    <QueryAllAccounts>true</QueryAllAccounts>
    <Properties>SendID</Properties>
    <Properties>SubscriberKey</Properties>
    <Properties>EventDate</Properties>
    <Properties>Client.ID</Properties>
    <Properties>EventType</Properties>
    <Properties>BatchID</Properties>
    <Properties>TriggeredSendDefinitionObjectID</Properties>
    <Properties>ListID</Properties>
    <Properties>PartnerKey</Properties>
    <Properties>SubscriberID</Properties>
  </RetrieveRequest>
</RetrieveRequestMsg>

  </soap:Body>
</soap:Envelope>

Post Reply