ODBC BigCommerce - cannot display linked orders table in Access

Discussion of open issues, suggestions and bugs regarding usage of ODBC Drivers
Post Reply
jgoemaat
Posts: 6
Joined: Mon 17 Dec 2018 23:08

ODBC BigCommerce - cannot display linked orders table in Access

Post by jgoemaat » Sat 24 Aug 2019 03:38

I have been using the ODBC Driver for BigCommerce version 1.5.10 for months now without issue including using several BigCommerce linked tables I created months ago in Microsoft Access 2016 ... using a System DSN on my Windows Server 2016 machine.

Recently I tried to open my linked table to the BigCommerce "orders" and it does not work - it just shows #NAME? for every field. There are only 44 records in this table.

I deleted the linked table and tried re-creating it and the same thing happens. All my other BigCommerce linked tables work and can be re-created just fine.

Has something changed perhaps with the BigCommerce API which is causing this error or perhaps some of the data returned from BigCommerce?

Strangely, I am able to run the query "select * from orders" as a pass through query using the system DSN and all the records DO show.

I tried to setup ODBC tracing but was not successful. Any ideas on this?

MaximG
Devart Team
Posts: 1390
Joined: Mon 06 Jul 2015 11:34

Re: ODBC BigCommerce - cannot display linked orders table in Access

Post by MaximG » Fri 06 Sep 2019 15:46

We've tested data retrieval from the "orders" table using our driver, but couldn't identify any issues. This behavior may be caused by specific values in the "orders" table in your account. Please send us the trace file that was generated during data retrieval using the ODBC Administrator utility.

Post Reply