Issues going from SDAC 7.3 to SDAC 8.3

Discussion of open issues, suggestions and bugs regarding SDAC (SQL Server Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
boutwater
Posts: 7
Joined: Fri 14 Aug 2009 14:00

Issues going from SDAC 7.3 to SDAC 8.3

Post by boutwater » Mon 22 Jul 2019 16:05

I just recently upgraded to SDAC 8.3 and my programs will compile, but will not run. So far, the issue I'm seeing is that it hangs when i try to set the MSConnection->Server. See bold line below for how I'm setting it.

MSConnection = new TMSConnection(NULL);
switch (MSSQLAuthorization) {
case Auth_Server: {
MSConnection->Authentication = auServer;
break;
}
default: {
MSConnection->Authentication = auWindows;
break;
}
}
MSConnection->ConnectionTimeout = 45;
MSConnection->Options->DefaultLockTimeout = 65000;
// MSConnection->Options->Provider = prNativeClient;
MSConnection->Username = UserID;
MSConnection->Password = Password;
MSConnection->Database = MSSQLDatabaseName;
MSConnection->LoginPrompt = false;
if (NotSet(MSSQLServerName)) {
strcpy(MSSQLServerName,"(local)");
}
MSConnection->Server = MSSQLDatabaseName;
MSQuery = new TMSQuery(NULL);
MSQuery->Connection = MSConnection;
MSQuery->LockMode = lmNone;
MSQuery->FetchAll = true;

Stellar
Devart Team
Posts: 320
Joined: Tue 03 Oct 2017 11:00

Re: Issues going from SDAC 7.3 to SDAC 8.3

Post by Stellar » Tue 23 Jul 2019 10:19

Unfortunately, we can't reproduce the issue. To investigate this behavior of SDAC, please compose a small sample demonstrating the issue and send it to us, including database objects creating scripts.
You can send the sample using the contact form at our site: devart.com/company/contactform.html

Post Reply