2.0 Version & Enums - Enums not being generated

Discussion of open issues, suggestions and bugs regarding EntityDAC
Post Reply
anykey
Posts: 8
Joined: Mon 14 May 2018 14:39

2.0 Version & Enums - Enums not being generated

Post by anykey » Thu 16 Aug 2018 14:49

Howdy,

In my project, I have numerous "Status" text fields on my entities that I would prefer to convert to Enums.

I have created a test project with a Parent / Child relationship... Created an Enum called "TestEnum" with 3 items "New", "Started" and "Closed".

I can add the Enum to either of the entities in the diagram. I can generate the class code for Delphi.

The property on the Entity is being added correctly in the generated SQL for the SQL Server database as TINYINT columns, seemingly correct.

The code generated references the Enums as properties of the generated classes. However, the Enums themself are not being generated in the code.

(Note: Complex Types are also not being generated. )

Suggestions?

Thanks, Tim

MaximG
Devart Team
Posts: 1138
Joined: Mon 06 Jul 2015 11:34

Re: 2.0 Version & Enums - Enums not being generated

Post by MaximG » Fri 17 Aug 2018 13:26

Thank you for the information. We will investigate the described issue and let you know the results shortly.

jwrz
Posts: 18
Joined: Mon 22 Aug 2016 05:30

Re: 2.0 Version & Enums - Enums not being generated

Post by jwrz » Sat 25 Aug 2018 17:27

I notice the same error.

MaximG
Devart Team
Posts: 1138
Joined: Mon 06 Jul 2015 11:34

Re: 2.0 Version & Enums - Enums not being generated

Post by MaximG » Tue 28 Aug 2018 10:41

Thank you for the information. We reproduced the issue and fixed this error. As a workaround, we can now send you a night build of our product. For this, provide your license number that you are using via the e-support form (https://www.devart.com/company/contactform.html)

Post Reply