Proxy difficulties

Discussion of issues, suggestions and bugs of Devart SSIS Data Flow Components, our product line for building SSIS-based ETL solutions, performing data access to popular cloud applications and databases.
Post Reply
SSF2400
Posts: 2
Joined: Thu 21 Jun 2018 10:30

Proxy difficulties

Post by SSF2400 » Fri 22 Jun 2018 07:39

Hi

I'm trying to connect to our MarketingCloud (ExactTarget) SOAP using one of the data flow components, but I'm getting error 407 (Proxy authentication required). How can I work around this? And preferably without having involve our IT department, as they are slow pokes. The proxy port on my MarketingCloud connection manager is set to 3128.

Thanks in advance.

Pinturiccio
Devart Team
Posts: 2227
Joined: Wed 02 Nov 2011 09:44

Re: Proxy difficulties

Post by Pinturiccio » Fri 22 Jun 2018 12:11

If you want to connect to your Salesforce Marketing Cloud via a proxy, you need to set the proxy parameters in your connection. For this, edit your ExactTarget connection, click Advanced and find proxy parameters: http://prntscr.com/jy078l

Can you connect with the "Proxy Host", "Proxy Password", "Proxy Port" and "Proxy User" parameters configured?

SSF2400
Posts: 2
Joined: Thu 21 Jun 2018 10:30

Re: Proxy difficulties

Post by SSF2400 » Fri 22 Jun 2018 13:08

I haven't set up a proxy, and the component won't allow me to remove the port 3128 as shown in your screenshot.

Pinturiccio
Devart Team
Posts: 2227
Joined: Wed 02 Nov 2011 09:44

Re: Proxy difficulties

Post by Pinturiccio » Sat 23 Jun 2018 09:56

It is the Visual Studio component validation. You can specify a null value for the integer property. 3128 is a default value. If you do not change it, the Proxy Port parameter is not even added to the result connection string.
SSF2400 wrote:I haven't set up a proxy
If we understood you correctly, the proxy connection is required in your situation. Thus, you need to specify proxy parameters for the proxy connection.

Post Reply