Errors after upgrade to Delphi 10.2.2

Discussion of open issues, suggestions and bugs regarding UniDAC (Universal Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
wjjw73
Posts: 22
Joined: Fri 17 Aug 2012 09:51

Errors after upgrade to Delphi 10.2.2

Post by wjjw73 » Wed 13 Dec 2017 12:25

Hello!

After todays upgrade to Delphi 10.2.2 I cannot compile my applications anymore!

Code: Select all

dcc32 Fatal error] U_DB.pas(6): F2051 Unit MemDS was compiled with a different version of System.Generics.Collections.TArray.Sort
I have a UniDAC license with source code and use the latest version of UniDAC (7.1.4).
Please help out!

Best regards,
Werner

Megabyte
Posts: 3
Joined: Tue 23 Sep 2014 07:50

Re: Errors after upgrade to Delphi 10.2.2

Post by Megabyte » Thu 14 Dec 2017 07:19

Hello,

I have the same problem.
Do you have a quick fix ?

Thank you in advance

wjjw73
Posts: 22
Joined: Fri 17 Aug 2012 09:51

Re: Errors after upgrade to Delphi 10.2.2

Post by wjjw73 » Thu 14 Dec 2017 10:24

Hello!

I already wrote to support - until now no response.

/Werner

grredford
Posts: 5
Joined: Thu 24 Apr 2014 17:11

Re: Errors after upgrade to Delphi 10.2.2

Post by grredford » Thu 14 Dec 2017 11:58

I have the same problem with MyDac (and I assume SDac but I've not checked it yet). I've logged a support request yesterday. I've also raised the issue on the Embarcadero site just in case something changed between Update 1 and Update 2). Just have to sit back and wait for a response.

MaximG
Devart Team
Posts: 1581
Joined: Mon 06 Jul 2015 11:34

Re: Errors after upgrade to Delphi 10.2.2

Post by MaximG » Thu 14 Dec 2017 13:56

We know about the compatibility issues of our products with the latest version of RAD Studio 10.2.2 Tokyo
We are planning DAC products release with support for RAD Studio 10.2.2 Tokyo in the shortest time

felixbcastillo
Posts: 33
Joined: Tue 25 Nov 2014 17:26

Re: Errors after upgrade to Delphi 10.2.2

Post by felixbcastillo » Thu 14 Dec 2017 17:04

We have to understand that a new IDE can come with things like this.
Thank you MaximG for the support!

I have the same problem, and I am also waiting for a solution!

Maybe your are waiting to solve other issues, but if there is a workaround with this one, we would appreciate it or even a testing version that we could be trying...

Megabyte
Posts: 3
Joined: Tue 23 Sep 2014 07:50

Re: Errors after upgrade to Delphi 10.2.2

Post by Megabyte » Sat 16 Dec 2017 15:32

Hello,

Do you know the release date?
Thank you in advance

Regards

igy
Posts: 1
Joined: Mon 18 Dec 2017 10:36

Re: Errors after upgrade to Delphi 10.2.2

Post by igy » Mon 18 Dec 2017 10:40

Hello,

Delphi Registered User Downloads
https://cc.embarcadero.com/reg/delphi

10.2.2 updated on Dec 17, 2017.

see also:
https://community.embarcadero.com/answe ... eply-13160

MaximG
Devart Team
Posts: 1581
Joined: Mon 06 Jul 2015 11:34

Re: Errors after upgrade to Delphi 10.2.2

Post by MaximG » Tue 19 Dec 2017 07:17

UniDAC 7.1.4 is not compatible with RAD Studio 10.2.2 Tokyo build 1978. The issue cause is not related to DAC products, but to some bugs in RAD Studio 10.2.2 build 1978. This bug is already fixed in RAD Studio 10.2.2 build 2004 from Dec 17, 2017. To solve the issue, install the studio build 2004 and install UniDAC again.

Post Reply