SecureBridge demo CRSSHIO failed

Discussion of open issues, suggestions and bugs regarding network security and data protection solution - SecureBridge
Post Reply
r1se
Posts: 6
Joined: Tue 28 Mar 2017 18:59

SecureBridge demo CRSSHIO failed

Post by r1se » Tue 28 Mar 2017 19:30

Hi.
I'm used Embarcadero 10.1 with unidac 6.4.16 and securebridge 7.3.4.
When i'm used unidac demo with SecureBridge, i'm have error CRSSHIOHandler - 'open failed'.
SSH connection work great, i'm can see connection.

MySQL configured by default(localhost 3306), from putty i can login on mysql.

Also im tried set Server Addres external api, don't help.

ViktorV
Devart Team
Posts: 2879
Joined: Wed 30 Jul 2014 07:16

Re: SecureBridge demo CRSSHIO failed

Post by ViktorV » Thu 30 Mar 2017 11:19

Unfortunately, we could not reproduce the issue. Please give a more detailed description of the problem: when exactly the error occurs, the exact error message, steps to reproduce, etc.

r1se
Posts: 6
Joined: Tue 28 Mar 2017 18:59

Re: SecureBridge demo CRSSHIO failed

Post by r1se » Fri 31 Mar 2017 08:25

raise exception on custom channel connect, i cant get more info, because dont have source.
Image

SecureBridge use only 22 port when try connecting to Mysql from Direct SSH? Or try open something more for mysql?
What is "open failed"?

ViktorV
Devart Team
Posts: 2879
Joined: Wed 30 Jul 2014 07:16

Re: SecureBridge demo CRSSHIO failed

Post by ViktorV » Fri 31 Mar 2017 09:52

MySQL server address is specified in the TUniConnection.Server property relatively to SSH server and there should be access from SSH server to MySQL server. If MySQL server is on the same machine where SSH server the TUniConnection.Server property should be set to "127.0.0.1" or "localhost" otherwise TUniConnection.Server should not include the value "127.0.0.1" or "localhost". MySQL server port is specified in the TUniConnection.Port property, but not SSH server port. Please, set the properties TUniConnection.Server (IP address of MySQL server) and TUniConnection.Port ( MySQL server port - by default - 3306) to the correct values and inform us about the result.
In our SSH demo sample, please set on the DB Connection panel, considering the above recommendations, the required values to connect to MySQL server and pre-connect to SSH server select "Direct SSH" and try to connect to MySQL server.

r1se
Posts: 6
Joined: Tue 28 Mar 2017 18:59

Re: SecureBridge demo CRSSHIO failed

Post by r1se » Fri 31 Mar 2017 12:10

On amazonEc2 server works fine.

On my hosting(timeweb.ru) error "open failed"
I'm try localhost, 127.0.0.1, 0.0.0.0

Image

ViktorV
Devart Team
Posts: 2879
Joined: Wed 30 Jul 2014 07:16

Re: SecureBridge demo CRSSHIO failed

Post by ViktorV » Fri 31 Mar 2017 12:28

Try to specify public IP address of MySQL server. Also, please specify whether SSH server and MySQL server are located on the same machine or different?

r1se
Posts: 6
Joined: Tue 28 Mar 2017 18:59

Re: SecureBridge demo CRSSHIO failed

Post by r1se » Fri 31 Mar 2017 13:34

public ip dont work.
I'n don't have information about location mysql, but from ssh i can connect throw mysql.

ViktorV
Devart Team
Posts: 2879
Joined: Wed 30 Jul 2014 07:16

Re: SecureBridge demo CRSSHIO failed

Post by ViktorV » Fri 31 Mar 2017 13:40

Please, provide a screenshot of the port forwarding settings in PUTTY.

r1se
Posts: 6
Joined: Tue 28 Mar 2017 18:59

Re: SecureBridge demo CRSSHIO failed

Post by r1se » Fri 31 Mar 2017 16:02

Putty on default settings
Image

ViktorV
Devart Team
Posts: 2879
Joined: Wed 30 Jul 2014 07:16

Re: SecureBridge demo CRSSHIO failed

Post by ViktorV » Fri 31 Mar 2017 16:28

Please provide information (ip and port of MySQL server) which you are using with putty.

r1se
Posts: 6
Joined: Tue 28 Mar 2017 18:59

Re: SecureBridge demo CRSSHIO failed

Post by r1se » Fri 31 Mar 2017 16:38

I'm used 127.0.0.1:3306 mysql from ssh console.

ViktorV
Devart Team
Posts: 2879
Joined: Wed 30 Jul 2014 07:16

Re: SecureBridge demo CRSSHIO failed

Post by ViktorV » Fri 31 Mar 2017 16:57

Please set the "Listen Port" to 3306, select "LocalPortForwarding" and try to connect to MySQL server.

Post Reply