Entity Framework Deployment Problem -Unable to find provider

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for MySQL
Post Reply
Posts: 37
Joined: Mon 23 Jun 2008 06:21
Location: Melbourne, Australia

Entity Framework Deployment Problem -Unable to find provider

Post by pleb » Tue 04 Nov 2008 01:00

Hi There,

I've built a little feed down loader which parses and saves the data in a database using the Entity Framework and MySQL provider.

I have some command lines args which force the creation and deletion of the database. These use raw ado.net and the MySQL driver. They work fine. :shock:

When I go to import the feed data I get this message
"The specified store provider cannot be found in the configuration, or is not valid."

However, when I run the command line program on my development box it works fine. :roll:

Initially I thought it'd be a dll missing from the deployment but CoreLab.Data and CoreLab.MySql are there.

Does anyone have any ideas, that I could try?


Devart Team
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Post by AndreyR » Tue 04 Nov 2008 11:04

You should add to the machine.config section the following lines: Also check that the assembly CoreLab.MySql.Entity is available for your application.

Posts: 37
Joined: Mon 23 Jun 2008 06:21
Location: Melbourne, Australia

Post by pleb » Wed 05 Nov 2008 00:42

Thank you for the hints.

I added the following to the app.config file (Machine config is a little to low level for one application)

Code: Select all

and included the CoreLab.MySql.Entity assembly in the deployment.

Posts: 1
Joined: Thu 05 May 2011 19:38
Location: Minneapolis

web.config solution

Post by whittet » Thu 05 May 2011 19:44

When deploying to another developer machine, adding the
bold section in web.config resolved my error.

Posts: 12
Joined: Mon 14 Mar 2011 12:49

Deploying WPF App with DotConnect for Oracle using ClickOnce

Post by dcuser » Fri 01 Jul 2011 10:09

Are you deploying using ClickOnce method or installSheild? We are having similar issues using clickOnce deployment method. I have tried both including the DBProviderFactory segment in app.config and including Oracle.Entity.dll file with the app. But, neither solves the error. I would appreciate any help.

Site Admin
Posts: 9543
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Fri 01 Jul 2011 15:42

dcuser, we have answered you in this thread: http://www.devart.com/forums/viewtopic.php?t=21401.

Post Reply