DbExpress 4.2 PDB in Oracle 19c protocol problem

Discussion of open issues, suggestions and bugs regarding usage of dbExpress drivers for Oracle in Delphi and C++Builder
Post Reply
tdobe
Posts: 4
Joined: Sat 10 Oct 2020 11:40

DbExpress 4.2 PDB in Oracle 19c protocol problem

Post by tdobe » Fri 30 Oct 2020 10:54

Now I have a problem with the protocol: ora-28040 no matching authentication protocol from Oracle

I used the option: SQLNET.ALLOWED_LOGON_VERSION_CLIENT=11 in the sqlnet.ora file but the problem still exists!

MaximG
Devart Team
Posts: 1650
Joined: Mon 06 Jul 2015 11:34

Re: DbExpress 4.2 PDB in Oracle 19c protocol problem

Post by MaximG » Fri 30 Oct 2020 14:39

Oracle 19c support is available in our driver starting with version 7.1.2 (28-Nov-19). What version of our driver are you using?

tdobe
Posts: 4
Joined: Sat 10 Oct 2020 11:40

Re: DbExpress 4.2 PDB in Oracle 19c protocol problem

Post by tdobe » Fri 30 Oct 2020 16:34

dbExpress 4.2 and Delphi 2007

MaximG
Devart Team
Posts: 1650
Joined: Mon 06 Jul 2015 11:34

Re: DbExpress 4.2 PDB in Oracle 19c protocol problem

Post by MaximG » Mon 02 Nov 2020 16:23

Oracle 19c didn't exist at the time dbExpress 4.2 was released, thus it may not be fully supported in that version.
You may need to upgrade your dbExpress driver to a newer version with support for Oracle 19c.

Post Reply