Lost resolution in TimeStamp column

Discussion of open issues, suggestions and bugs regarding usage of dbExpress drivers for Oracle in Delphi and C++Builder
Post Reply
Posts: 1
Joined: Thu 09 Jun 2016 09:34

Lost resolution in TimeStamp column

Post by areales » Thu 09 Jun 2016 09:53

At present we are working with “dbExpress Driver for Oracle”, version "” in Delphi 2007 without any problems.
Today, I’m testing the same component but different version ( in Delphi 10 and I have a problem.
I’m retrieving data form BBDD Oracle executing a TSQLStoreProc and one of the columns is a Timestamp column. This column have a milliseconds in the BBDD but when I read the value from Delphi, the milliseconds (Fractions) always show 0(zero), other values are correct
I tried to read this column from Delphi like a “TimeStamp”, “String”, “DateTime” with the same result, the milliseconds return zero.


-Work in Delphi 2007, driver version(dbxoda.dll), Windows 7. Oracle client 10g R2
-It does not work in Delphi 10, driver version(dbxoda.dll), Windows 10. . Oracle client 11g R1

Any idea?

Thanks in advance.

Devart Team
Posts: 5530
Joined: Tue 10 Aug 2010 11:35

Re: Lost resolution in TimeStamp column

Post by AlexP » Tue 14 Jun 2016 12:34

Please send a small sample demonstrating the issue with timestamp to support*devart*com , including scripts for creating and populating the table and storedprocedure.

Post Reply