Page 1 of 1

DisposeBuf failed (D:\Projects\Delphi\Dac\Source\MemData.pas, line 4436)

Posted: Tue 14 Jun 2005 17:39
by dougcl
Hello, it appears that this message sometimes occurs when ApplyUpdates is called. Normally everything is fine. Any clues?

Thanks,
Doug

Posted: Tue 21 Jun 2005 09:56
by Ikar
We couldn't reproduce the problem.
Please send us (mydac*crlab*com) complete small sample to demonstrate it.

Posted: Tue 21 Jun 2005 23:39
by Guest
I am also experiencing this problem.
Error Mge. DisposeBuffaile (D:\Projects\Delphi\Dac\Source\MemData.pas, line 4342)

This error occurs on a form that has 10 queries, 8 tables and a number of lookup fields.

I am using SDAC245d7

cheers

DisposeBuf Failed

Posted: Tue 21 Jun 2005 23:41
by Guest
Anonymous wrote:I am also experiencing this problem.
Error Mge. DisposeBuf failed(D:\Projects\Delphi\Dac\Source\MemData.pas, line 4342)

This error occurs on a form that has 10 queries, 8 tables and a number of lookup fields.

I am using SDAC245d7

cheers

Posted: Wed 22 Jun 2005 06:41
by Paul
Please send us complete small sample project to demonstrate the problem to SDAC support address (sdac*crlab*com). Please specify version of SDAC

Posted: Wed 22 Jun 2005 19:04
by dougcl
Hi Paul, thanks for the response. Unfortunately, the problem is inconsistent, and happens rarely. Maybe four times in a 24 hr period with a user base of about 10. I have never been able to reproduce the problem on my computer. I'm looking for any ideas that you might have that would relate to this error.

One theory (since it's intermittent) is that it is hardware related. Our machines might be underpowered under certain circumstances. Does this error correspond to a memory allocation?

I am thinking that perhaps it is something related to the use of cached updates. Do you suppose it's worthwhile to turn off cached updates and let the controls handle themselves? Is this error related to the use of cached updates?

etc.

Thanks,
Doug

Posted: Thu 23 Jun 2005 07:43
by Paul
Yes, this is a memory problem concerning working with records and can happen with cached updates.
You are using older version of SDAC. Possibly this problem is fixed in the last version.

Posted: Thu 23 Jun 2005 23:45
by dougcl
Thanks Paul,
You are correct. I am running an old version. The install file is sdac245d7.exe. Is it possible to patch or upgrade?

Thanks,
Doug

Posted: Wed 27 Jul 2005 17:16
by dougcl
Hi,
I have upgraded to the latest version, and I still have the problem. Is there any information that you can give me that can help me find the cause of this error? I have no idea where to look. I am using cached updates and I am calling ApplyUpdates to write to the database. Should I stop using cached updates? Is it unreliable?

Thanks,
Doug

Posted: Wed 03 Aug 2005 08:59
by Ikar
What exact SDAC version (X.XX.XX.XX) have you upgraded for?

According to using CachedUpdates you use not VirtualTable but some another component/

If you cannot reproduce the problem try to set Options.FlatBuffer := True. It is not the best way but may help.

Posted: Wed 03 Aug 2005 20:43
by dougcl
Thanks Ikar,
The version is your latest one for SDAC 2:
SDAC 2 version 2.45.2.29 from 29.04.04

I don't understand this sentence:

"According to using CachedUpdates you use not VirtualTable but some another component"

Perhaps you can tell me why the DisposeBuf error happens, or something about it that will help me find the problem.

Thanks,
Doug

Posted: Thu 04 Aug 2005 08:12
by Ikar
> I don't understand this sentence:
> "According to using CachedUpdates you use not VirtualTable but some another
> component"

This forum is related to VirtualTable discussion. You might ask your question at SDAC forum.

> Perhaps you can tell me why the DisposeBuf error happens, or something about
> it that will help me find the problem.


It may concern using TCustomDADataSet.Options.FlatBuffers = True, or TCustomDADataSet.CachedUpdates.