random lost data

Discussion of open issues, suggestions and bugs regarding MyDAC (Data Access Components for MySQL) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
TobiasHo
Posts: 2
Joined: Thu 11 Jul 2019 09:12

random lost data

Post by TobiasHo » Thu 11 Jul 2019 09:30

I am using Delphi XE6 with the latest mydac components on a MySQL 5.5.62-0ubuntu0.14.04.1

My invoice program is really simple with a head and an item table. (TMyConnection->TMyTable)
Sometimes the following problem occurs:

I enter data - everything is fine - I can scroll through my invoices, also the detail table shows the right data. Then I leave my program and re-enter. And the work of a day or so is lost. Like a cache is not wirtten properly to the disk. Within this time my MySQL server is always on - no restart or so. I can´t reproduce the error, the problem occurs randomly.

I checked many times that all table cachedupdates are set to false. What could be the reason for this behaviour? Maybe a problem with my MySQL configuration?
I don´t understand why I can browse through my invoices without any problem - where did this data come from and after closing the app the data is gone.

ViktorV
Devart Team
Posts: 2793
Joined: Wed 30 Jul 2014 07:16

Re: random lost data

Post by ViktorV » Fri 12 Jul 2019 11:45

This behavior may occur if you've made changes to your program, but they haven't been sent to the server.
You can use dbMonitor to find out what information is sent to the server, as well as when it is sent to the server . If this doesn't help you solve the task, please compose a small sample demonstrating the described behavior and send it us using the contact form https://devart.com/company/contactform.html, along with scripts for creating and populating database objects.

TobiasHo
Posts: 2
Joined: Thu 11 Jul 2019 09:12

Re: random lost data

Post by TobiasHo » Mon 22 Jul 2019 14:46

I just downloaded dbmonitor - everything seems fine. Every edit, add etc. is sent correctly. I can see the start and commit commands in the log. (I only use Tables so I think mydac uses the transactions automatically)
Most of the time 99.9% the program works - only sometimes it doesn´t... As I can´t reproduce the failure - I can´t send you logfiles.

ViktorV
Devart Team
Posts: 2793
Joined: Wed 30 Jul 2014 07:16

Re: random lost data

Post by ViktorV » Tue 23 Jul 2019 05:31

Unfortunately, we cannot reproduce the problem in our environment based on the data you provide. The error may not be in the MyDAC code. Therefore, the only way to solve it, try to compile and send us an example of a reproducing error. As soon as we get such an example and the problem will be reproduced in our environment and we will try to give you an answer right away. If the cause of the error is in our code, we will fix it as soon as possible.

Post Reply