is a Bug?

Discussion of open issues, suggestions and bugs regarding MyDAC (Data Access Components for MySQL) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
eduardosic
Posts: 387
Joined: Fri 18 Nov 2005 00:26
Location: Brazil

is a Bug?

Post by eduardosic » Sun 19 Feb 2006 00:42

I using myDAC 4.30 in Delphi 7 application, the server running Windows Xp Professional, the station running Windows 98.

the exceptions is raised:

1 - Lost Connection to MySQL server during query
Socket error on read, WSAGetLastErros return 10053($2745)

2 - #HY000'ID' From 'Thread' 223 Unknwon.

3 - Lost Connection to MySQL server during query.

in myDAC 4.00.2.8, the exceptions never is raised.

set TmyConnection.Direc := False is a temporary Solution?

All the TmyQuery.FetchAll = False.

GEswin
Posts: 186
Joined: Wed 03 Nov 2004 16:57
Location: Spain
Contact:

Post by GEswin » Sun 19 Feb 2006 13:36

You should post more details when this exceptions happens. If it happens when opening a query, connecting, etc.. Also remember that if you work with threads you should use a connection for each thread.

eduardosic
Posts: 387
Joined: Fri 18 Nov 2005 00:26
Location: Brazil

ok...

Post by eduardosic » Sun 19 Feb 2006 22:50

GEswin wrote:You should post more details when this exceptions happens. If it happens when opening a query, connecting, etc.. Also remember that if you work with threads you should use a connection for each thread.

this exception occurs when call method Dataset.close;

As I must use a connection for each thread, in the previous versions of myDAC this never happened.

swierzbicki
Posts: 451
Joined: Wed 19 Jan 2005 09:59

Post by swierzbicki » Mon 20 Feb 2006 07:49

There is a few workarround :

set Fetchall = True

or

set fetchall = False and BEFORE closing the table do Table.last

or

update to latest Mysql 5.x

Antaeus
Posts: 2098
Joined: Tue 14 Feb 2006 10:14

Post by Antaeus » Mon 20 Feb 2006 07:58

This is MyDAC bug. Please see our answer in http://crlab.com/forums/viewtopic.php?p=9442 thread.

eduardosic
Posts: 387
Joined: Fri 18 Nov 2005 00:26
Location: Brazil

i Know, but???

Post by eduardosic » Mon 20 Feb 2006 12:27

Antaeus wrote:This is MyDAC bug. Please see our answer in http://crlab.com/forums/viewtopic.php?p=9442 thread.
I know, I initiated that one thread, and for exceptions:

1 - Lost Connection to MySQL server during query
Socket error on read, WSAGetLastErros return 10053($2745)

3 - Lost Connection to MySQL server during query.


i upgrade mySQL to last version but this exception occurs.

when new release of myDAC is available?

thanks.

Antaeus
Posts: 2098
Joined: Tue 14 Feb 2006 10:14

Post by Antaeus » Mon 20 Feb 2006 13:31

New build of MyDAC will be available during nearest two weeks.

Post Reply