inserting large data of size > 16 MB fails

Discussion of open issues, suggestions and bugs regarding MyDAC (Data Access Components for MySQL) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
Posts: 5
Joined: Fri 25 Nov 2005 07:55

inserting large data of size > 16 MB fails

Post by arunv2000 » Fri 25 Nov 2005 08:07

I use MySQL version 4.0.16. and MyDAC version on Borland C++ Builder 6.0.

I am trying to insert some in-memory data of size > 16 MB in a Blob field in MySQL. I get an error message saying 'MySQL server has gone away'.

After reading the FAQ on this site, i also tried setting the 'MyConnection->ConnectionTimeout' to 1000 seconds, a large enough number. Still I get the same error.

However, I am able to insert the same data from the MySQL command prompt (after setting the *max_packet_size* and *wait_timeout*)

According to the MySQL help,
"... You also get a lost connection if you are sending a packet 16MB or larger if your client is older than 4.0.8 and your server is 4.0.8 and above, or the other way around...."

Is there a MyDAC version that corresponds to MySQL version > 4.0.8?

Your help is appreciated in advance.


Posts: 1693
Joined: Thu 28 Oct 2004 13:56

Post by Ikar » Fri 25 Nov 2005 11:35

Please update MyDAC to As registered user you can do it for free. Please see you registration letter for details.
Also try to change MyConnection.Options.Direct value.

Post Reply