Error when open the TMyTable

Discussion of open issues, suggestions and bugs regarding MyDAC (Data Access Components for MySQL) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
ManUtd
Posts: 24
Joined: Thu 20 Oct 2005 02:48

Error when open the TMyTable

Post by ManUtd » Mon 24 Oct 2005 03:32

We use MyDAC Versopm 4 connection to MySQL 4.1

At design time, I set the TMyTable Active to True and got the error:
"A call to an mysql_server_init failed.
C:\Temp\EmbedExperiment|data\ibdata1 - The file exisits
C:\Temp\EmbedExperiment|data\ib_logfile0 - The file exisits"

I copied these files from the MySQL Server data directory. Should I ?

Ikar
Posts: 1693
Joined: Thu 28 Oct 2004 13:56

Post by Ikar » Mon 24 Oct 2005 12:59

Most possible, you connect to one datafolder from two different instances of embedded server. These are probably connections from Delphi IDE (design-time) and your application (run-time).

ManUtd
Posts: 24
Joined: Thu 20 Oct 2005 02:48

Post by ManUtd » Wed 26 Oct 2005 01:17

>>Most possible, you connect to one datafolder from two different instances of embedded server.<<

What is this mean ?

alec
Posts: 20
Joined: Wed 24 Aug 2005 09:28
Location: Africa

Re: Error when open the TMyTable

Post by alec » Wed 26 Oct 2005 04:08

ManUtd wrote:C:\Temp\EmbedExperiment|data\ibdata1 - The file exisits
C:\Temp\EmbedExperiment|data\ib_logfile0 - The file exisits"
Symbol '|' not valid for windows filesystems.

Ikar
Posts: 1693
Joined: Thu 28 Oct 2004 13:56

Post by Ikar » Thu 27 Oct 2005 06:29

You run one application twice or more, or connect to server in design-time too.

Post Reply