Problem MyDAC application

Discussion of open issues, suggestions and bugs regarding MyDAC (Data Access Components for MySQL) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
Posts: 1
Joined: Wed 19 Oct 2005 12:50

Problem MyDAC application

Post by Jeroen » Wed 19 Oct 2005 16:30

Last Saturday I bought MySQL Data Access Components Standard at your company.

After installing it on my pc I start to program. But there is a problem:

I build a simple application with the MyDac component on it. When I run this application on the developer pc where Borland Delphi 2005 and

the MyDAC component is installed the program will work fine. But if I run it on a workstation is raises an exception at startup.

Then the program gives the following error in the log file with the Assembly Binding Log Viewer :


*** Assembly Binder Log Entry (18-10-2005 @ 17:23:39) ***

The operation failed.

Bind result: hr = 0x80131040. No description available.

Assembly manager loaded from: C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\fusion.dll

Running under executable E:\KassaSysteem\testMYDAC\Project2.exe

--- A detailed error log follows.

=== Pre-bind state information ===

LOG: DisplayName = Borland.Delphi, Version=9.0.1761.24408, Culture=neutral, PublicKeyToken=91d62ebb5b0d1b1b


LOG: Appbase = E:\KassaSysteem\testMYDAC\

LOG: Initial PrivatePath = NULL

LOG: Dynamic Base = NULL

LOG: Cache Base = NULL

LOG: AppName = NULL

Calling assembly : CoreLab.Dac, Version=, Culture=neutral, PublicKeyToken=09af7300eec23701.


LOG: Processing DEVPATH.

LOG: DEVPATH is not set. Falling through to regular bind.

LOG: Publisher policy file is not found.

LOG: Host configuration file not found.

LOG: Using machine configuration file from C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\config\machine.config.

LOG: Post-policy reference: Borland.Delphi, Version=9.0.1761.24408, Culture=neutral, PublicKeyToken=91d62ebb5b0d1b1b

LOG: Cache Lookup was unsuccessful.

LOG: Attempting download of new URL file:///E:/KassaSysteem/testMYDAC/Borland.Delphi.DLL.

LOG: Assembly download was successful. Attempting setup of file: E:\KassaSysteem\testMYDAC\Borland.Delphi.DLL

LOG: Entering run-from-source setup phase.

WRN: Comparing the assembly name resulted in the mismatch: Revision Number

ERR: The assembly reference did not match the assembly definition found.

ERR: Failed to complete setup of assembly (hr = 0x80131040). Probing terminated.


Maybe there is a standard solution for this problem? If you know the answer

Please let us know.

The application files

Posts: 1693
Joined: Thu 28 Oct 2004 13:56

Post by Ikar » Thu 20 Oct 2005 13:54

Please try to compile your project without using assemblies.

Post Reply