Azure connect with AAD not work

Discussion of open issues, suggestions and bugs regarding SDAC (SQL Server Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
sqlpat
Posts: 1
Joined: Fri 05 Jun 2020 08:55

Azure connect with AAD not work

Post by sqlpat » Fri 05 Jun 2020 10:25

Hello

I wanna connect to a Azure SQL Database with Azure Active Directory Login. I will use a connectionstring like this:

Server=tcp:mysql.database.windows.net,1433;Initial Catalog=myDB;Persist Security Info=False;MultipleActiveResultSets=False;Encrypt=True;TrustServerCertificate=False;Authentication="Active Directory Integrated"

Then i will bevome this error: "Login failed for user sa".

Is the SDAC Component not compatible with Azure Active Directory Authentication ?

many thanks for help.

Kindly Regards
Pat

Stellar
Devart Team
Posts: 359
Joined: Tue 03 Oct 2017 11:00

Re: Azure connect with AAD not work

Post by Stellar » Thu 18 Jun 2020 14:55

We will consider a possibility of the specified functionality in one of the next SDAC version. If you want us to implement the feature, please post it at our user voice forum: https://devart.uservoice.com/forums/104 ... y_id=18939. If the suggestion gets a lot of votes, we will consider the possibility to implement it.

upscene
Posts: 282
Joined: Thu 19 Oct 2006 08:13

Re: Azure connect with AAD not work

Post by upscene » Thu 25 Jun 2020 07:52

I second this, having full Active Directory support would be great.

https://docs.microsoft.com/en-us/azure/ ... d-overview

Stellar
Devart Team
Posts: 359
Joined: Tue 03 Oct 2017 11:00

Re: Azure connect with AAD not work

Post by Stellar » Fri 26 Jun 2020 13:50

We'll consider implementing a new authentication method (Active Directory – Universal with MFA support, Active Directory, Password Active Directory - Integrated) in future releases of SDAC.

Post Reply