SDAC 8.0.4 RefreshQuick Problem

Discussion of open issues, suggestions and bugs regarding SDAC (SQL Server Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
wishmaster
Posts: 8
Joined: Sat 26 Apr 2014 19:00

SDAC 8.0.4 RefreshQuick Problem

Post by wishmaster » Fri 26 Jan 2018 09:31

Hi,
We select some data from a parameterized table valued function.
Till 8.0.4 we haven't got any problems, the table and function both have timestamp fields and refreshquick works perfect. With 8.0.4 we start to get "The multi-part identifier "xxx.dbo.xxx.timestamp" could not be bound. the fieldname is [timestamp] and it's data type is timestamp. The query itself have no problems, we got this error when we refreshquick only.

Thanks

wishmaster
Posts: 8
Joined: Sat 26 Apr 2014 19:00

Re: SDAC 8.0.4 RefreshQuick Problem

Post by wishmaster » Fri 26 Jan 2018 09:55

I return back to 8.0.3 and problem gone, so I can confirm again this is related to 8.0.4.

Now I've another problem, as I understand 8.0.4 adds new property to all my hundreds of TMSQuery compnents, after downgrading to 8.0.3 I started to get:

Code: Select all

.... Error reading Table.Constraints: Property Constraints does not exists. Ignore the error and continue? ....

Stellar
Devart Team
Posts: 102
Joined: Tue 03 Oct 2017 11:00

Re: SDAC 8.0.4 RefreshQuick Problem

Post by Stellar » Tue 30 Jan 2018 13:45

We tested the work of SDAC 8.0.4, but unfortunately found no problems when retrieving data with the table-valued function. In order for us to analyze the issue, please send us a sample demonstrating this issue, as well as a script for creating the function and the table.

In the new SDAC 8.0.4 version, the Constraints property was added to the TMSQuery class. You can ignore the "Property Constraints does not exist" error, because the TMSQuery class did not have the Constraints property, and dfm-reader finds this property stored in the dfm-file and does not find this property in the TMSQuery class.

wishmaster
Posts: 8
Joined: Sat 26 Apr 2014 19:00

Re: SDAC 8.0.4 RefreshQuick Problem

Post by wishmaster » Sun 11 Feb 2018 01:19

Hi Stellar,
Sorry it takes a lot of time to prepare the same environment to reporoduce the bug.
Can you send me email address to send the demo project to?

Thanks

Stellar
Devart Team
Posts: 102
Joined: Tue 03 Oct 2017 11:00

Re: SDAC 8.0.4 RefreshQuick Problem

Post by Stellar » Mon 12 Feb 2018 12:28

Please leave your request including details of the issue and an example at e-support ( https://www.devart.com the "Support"\"Request Support" menu ).

Post Reply