Problem with field ALIAS

Discussion of open issues, suggestions and bugs regarding SDAC (SQL Server Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
m.deltoso
Posts: 9
Joined: Wed 10 Dec 2014 09:19

Problem with field ALIAS

Post by m.deltoso » Mon 19 Jun 2017 08:33

Dear Devart,

we notice a strange problem with your TMSQuery component since the last update to version 8.0.2.
We use a query with field aliases and since last version we noticed that this fields are not updated if modified. If we use the dbMonitor, the update command does not contain the update of all fields from the updating table wich have an alias.
For example, with this query:

Code: Select all

SELECT
  A.FIELD_1,
  A.FIELD_2,
  A.FIELD_3 AS NEW_FIELD_NAME,
  B.FIELD_A
FROM
  TABLE_1 A LEFT OUTER JOIN
  TABLE_2 B ON A.FIELD_2 = B.FIELD_2
if we update the value of field NEW_FIELD_NAME (wich is A.FIELD_3) the corresponding updating command does not contains the update of this field.
With old versions of your components the update works great. Did you change the behaviour for the creation of the update command of the TMSQuery component in new version? Or is it a bug?
This is a big problem for us because we have a lot of programs that use your component with field alias.

Thanks in advance

ViktorV
Devart Team
Posts: 2299
Joined: Wed 30 Jul 2014 07:16

Re: Problem with field ALIAS

Post by ViktorV » Tue 20 Jun 2017 11:00

Unfortunately, we could not reproduce the problem.
In order to get a detailed answer, please compose a small sample demonstrating the difference in behavior between SDAC versions and send it to us using the contact form https://www.devart.com/company/contactform.html including scripts for creating and filling database objects. Also please specify the exact version of the used SQL Server.

m.deltoso
Posts: 9
Joined: Wed 10 Dec 2014 09:19

Re: Problem with field ALIAS

Post by m.deltoso » Fri 07 Jul 2017 10:25

Hi Viktor,

i send to you a full mail (using the contact form you suggested me) with an example to show the wrong behaviour i mentioned in the previous post.
Did you receive the mail? Are you working on it?

Thanks in advance

ViktorV
Devart Team
Posts: 2299
Joined: Wed 30 Jul 2014 07:16

Re: Problem with field ALIAS

Post by ViktorV » Fri 07 Jul 2017 11:02

Unfortunately, we have not received a letter from you with the example, demonstrating the issue. For a faster response, please send your sample to viktorv*devart*com

ViktorV
Devart Team
Posts: 2299
Joined: Wed 30 Jul 2014 07:16

Re: Problem with field ALIAS

Post by ViktorV » Tue 11 Jul 2017 09:27

Thank you for the information. We have reproduced the issue and investigation is in progress. We will inform you when we have any results.

m.deltoso
Posts: 9
Joined: Wed 10 Dec 2014 09:19

Re: Problem with field ALIAS

Post by m.deltoso » Tue 01 Aug 2017 12:02

Hi Devart,
I have not received any communication yet about the reported problem. Is it possible to have at least one estimate on when the problem will be resolved?

ViktorV
Devart Team
Posts: 2299
Joined: Wed 30 Jul 2014 07:16

Re: Problem with field ALIAS

Post by ViktorV » Wed 02 Aug 2017 09:56

We have already fixed the issue. This fix will be included in the next build of SDAC.

m.deltoso
Posts: 9
Joined: Wed 10 Dec 2014 09:19

Re: Problem with field ALIAS

Post by m.deltoso » Wed 02 Aug 2017 10:23

Thank you for the information. When will the next release be published?

ViktorV
Devart Team
Posts: 2299
Joined: Wed 30 Jul 2014 07:16

Re: Problem with field ALIAS

Post by ViktorV » Wed 02 Aug 2017 10:43

We are planning to release a new SDAC version next month.

Post Reply