Error: The specified Table-Valued Parameter type dbo.XXX could not be located on the server

Discussion of open issues, suggestions and bugs regarding SDAC (SQL Server Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
ezijp
Posts: 6
Joined: Tue 23 Feb 2016 12:02

Error: The specified Table-Valued Parameter type dbo.XXX could not be located on the server

Post by ezijp » Tue 09 May 2017 05:33

While evaluating the trial version of SDAC I stumbled upon the following error:

---------------------------
Debugger Exception Notification
---------------------------
Project XXXX.exe raised exception class EMSError with message 'One or more errors occurred while attempting to retrieve metadata information for InMemory Rowset. Check other errors for details. InMemory Rowset creation failed.
The specified Table-Valued Parameter type dbo.XXX could not be located on the server.'.
---------------------------
Break Continue Help
---------------------------

This happens when I try to use a Table Valued Parameter. TVP's are the only reason to purchase SDAC, because we already use UniDAC. The database is set at compatibility level for SQL Server 2008 (level 100). The error happens when connecting to a SQL Server 2012 SP1 instance, but it doesn't happen when connecting to a SQL Server 2016 (no SP). The User defined table consists of a date field and a bigint field.

Kind regards,
Erik

azyk
Devart Team
Posts: 1057
Joined: Fri 11 Apr 2014 11:47
Location: Alpha Centauri A

Re: Error: The specified Table-Valued Parameter type dbo.XXX could not be located on the server

Post by azyk » Thu 11 May 2017 14:26

We tried to reproduce the specified error according to the recommendations, however it was not reproduced. Please compose a small test project which demonstrates it and send to us using the contact form at our site: http://www.devart.com/company/contactform.html . In the sample include test DB backup.

Also specify the exact SQL Server version on which the error is reproduced.

ezijp
Posts: 6
Joined: Tue 23 Feb 2016 12:02

Re: Error: The specified Table-Valued Parameter type dbo.XXX could not be located on the server

Post by ezijp » Thu 11 May 2017 15:18

Thanks, I found the problem while trying to create a test case. On the sql 2012 instance the role was missing the VIEW DEFINITION permission. :oops:

Post Reply