Text field getting corrupted

Discussion of open issues, suggestions and bugs regarding SDAC (SQL Server Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
mervinpearce
Posts: 16
Joined: Mon 08 Oct 2012 14:08

Text field getting corrupted

Post by mervinpearce » Tue 28 Feb 2017 04:48

I am starting some trouble shooting whereby suddenly I am getting corruption of text fields. I just want to see where this is occurring. Latest version of SDAC, running on SQL 2016. Tracing through code the values to be posted is correct but final data is not. Attached is a screenshot.
- going to try on SQL 2014
- Also will try and rollback components
The question here is if there is any similar issues?
Image

mervinpearce
Posts: 16
Joined: Mon 08 Oct 2012 14:08

Re: Text field getting corrupted

Post by mervinpearce » Tue 28 Feb 2017 05:55

Checked against SQL 2014, same corruption.
Any location to download previous versions of SDAC? (ODAC,LiteDAC,etc) as I use the complete suite

ViktorV
Devart Team
Posts: 2299
Joined: Wed 30 Jul 2014 07:16

Re: Text field getting corrupted

Post by ViktorV » Tue 28 Feb 2017 07:27

To investigate this SDAC behavior, please compose a small sample demonstrating the described behavior and send it using the contact form https://www.devart.com/company/contactform.html including scripts for creating database objects.
You will have to download previous versions of our products from our website secure.devart.com using the credentials you got when buying the product. The link to the previous versions is in the bottom of the current version page.

mervinpearce
Posts: 16
Joined: Mon 08 Oct 2012 14:08

Re: Text field getting corrupted

Post by mervinpearce » Tue 28 Feb 2017 18:21

Please close. This was my error. I enabled Blob Compression on the one SQL component and not the other which is separate for the report. Your components are working as designed. Rocking

<blush>

ViktorV
Devart Team
Posts: 2299
Joined: Wed 30 Jul 2014 07:16

Re: Text field getting corrupted

Post by ViktorV » Wed 01 Mar 2017 07:24

We are glad to see you have found a solution.
Feel free to contact us if you have any further questions about our products.

Post Reply