Connecting fail within an IPv6-only network

Discussion of open issues, suggestions and bugs regarding SDAC (SQL Server Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Misut
Posts: 5
Joined: Fri 01 Jul 2016 09:47

Connecting fail within an IPv6-only network

Post by Misut » Fri 01 Jul 2016 09:56

A device connected to an IPv4 network has no problem to connect.

Same device connected to an IPv6 network can't connect to our sql server.

MSConnection.Provider is prDirect if that helps.

Could it be that MSConnection is resolving our server's name to an IPv4 address?

Thank you very much in advance.

ViktorV
Devart Team
Posts: 2122
Joined: Wed 30 Jul 2014 07:16

Re: Connecting fail within an IPv6-only network

Post by ViktorV » Fri 01 Jul 2016 15:01

Currently, SDAC doesn't support IPv6 protocol in Direct Mode. We will try to add this support in the next SDAC release.

Misut
Posts: 5
Joined: Fri 01 Jul 2016 09:47

Re: Connecting fail within an IPv6-only network

Post by Misut » Fri 01 Jul 2016 15:43

We need this feature in order to connect from iOS under an IPv6 network.

Would it be possible to get a sooner build or fix resolving this issue?

Misut
Posts: 5
Joined: Fri 01 Jul 2016 09:47

Re: Connecting fail within an IPv6-only network

Post by Misut » Mon 04 Jul 2016 14:49

What I don't understand is why is possible that I can connect from Android within an IPv6-only network with no problem, when SDAC doesn't support IPv6 protocol in Direct Mode.

We have problems connecting only under an iOS environment connected to an IPv6 network.

This is a mandatory requirement from Apple review, so our apps are not being approved because of this reason :cry:

ViktorV
Devart Team
Posts: 2122
Joined: Wed 30 Jul 2014 07:16

Re: Connecting fail within an IPv6-only network

Post by ViktorV » Tue 05 Jul 2016 10:18

Support for the IPv6 protocol in Direct Mode is being implemented. As soon as we implement it, we will be able to send you a nigh build of SDAC including this functionality.

Misut
Posts: 5
Joined: Fri 01 Jul 2016 09:47

Re: Connecting fail within an IPv6-only network

Post by Misut » Tue 05 Jul 2016 11:00

I am so happy to read that!!!

We are making crazy :roll:

Thank you so much for your support.

ViktorV
Devart Team
Posts: 2122
Joined: Wed 30 Jul 2014 07:16

Re: Connecting fail within an IPv6-only network

Post by ViktorV » Mon 11 Jul 2016 07:40

We can send you a SDAC night build with support for the IPv6 protocol in Direct Mode. Please provide your license number and IDE version to viktorv*devart*com and we will send you a night build.

WestyOz
Posts: 18
Joined: Tue 23 Jun 2015 06:18

Re: Connecting fail within an IPv6-only network

Post by WestyOz » Fri 02 Sep 2016 01:21

This is also affecting our applications - I am hoping that I also can receive a night build that contains this support? I will send an email with a request through referencing this thread.

Our applications are being rejected from the app store so this has become a reasonably critical problem....so appreciate any assistance.

ViktorV
Devart Team
Posts: 2122
Joined: Wed 30 Jul 2014 07:16

Re: Connecting fail within an IPv6-only network

Post by ViktorV » Fri 02 Sep 2016 08:02

We are going to release a new build of SDAC including support for IPv6 protocol next week.

WestyOz
Posts: 18
Joined: Tue 23 Jun 2015 06:18

Re: Connecting fail within an IPv6-only network

Post by WestyOz » Mon 05 Sep 2016 04:10

Thanks VictorV - appreciate the feedback - looking forward to the new release.

WestyOz
Posts: 18
Joined: Tue 23 Jun 2015 06:18

Re: Connecting fail within an IPv6-only network

Post by WestyOz » Thu 08 Sep 2016 22:41

Just checking in - is the SDAC still on track for release this week?

ViktorV
Devart Team
Posts: 2122
Joined: Wed 30 Jul 2014 07:16

Re: Connecting fail within an IPv6-only network

Post by ViktorV » Fri 09 Sep 2016 10:13

The new SDAC 7.3.14 including support for IPv6 protocol is already available for download now.

alexvm73@hotmail.com
Posts: 1
Joined: Fri 09 Sep 2016 15:43

Re: Connecting fail within an IPv6-only network

Post by alexvm73@hotmail.com » Fri 09 Sep 2016 15:49

Hi. may yo give an example to use ipv6 in direct mode in this new relase version please?
i download and install this current version and can not do an succesfull connection via ipv6
help! thankyou in advance!

WestyOz
Posts: 18
Joined: Tue 23 Jun 2015 06:18

Re: Connecting fail within an IPv6-only network

Post by WestyOz » Sun 11 Sep 2016 22:54

Not sure if this applies to your situation alexvm73 - but the way I have tested this is by setting up my Mac (for iOS app) in the IPv6 configuration (https://developer.apple.com/library/ios ... ition.html) .

Then in my Delphi project I extended the existing TMSConnection with the option 'IPVersion' (ie connection.Options.IPVersion) and set this to CRVio.ivIPBoth.

Then build/deploy the application to the iOS device for testing on the MAC IPv6 (NAT64) wireless network. Make sure though that the iOS device has the mobile data option (under Settings -> Mobile) turned off when testing.

This seems to have worked - will be doing some more testing but all good so far.

Thanks to the Devart team for the turnaround on this one - much appreciated.

azyk
Devart Team
Posts: 1008
Joined: Fri 11 Apr 2014 11:47
Location: Alpha Centauri A

Re: Connecting fail within an IPv6-only network

Post by azyk » Tue 13 Sep 2016 08:49

If you need to use only IPv6, then set the TMSConnection.Options.IPVersion property to ivIPv6. If you need both IPv4 and IPv6 protocols - to ivIPBoth.

In order to use ivIPv6 and ivIPBoth constants, add the CRVio unit to the Uses section.

Post Reply