Cannot set Pooling on non-1433 port

Discussion of open issues, suggestions and bugs regarding SDAC (SQL Server Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
wkotze@wccsoft.co.za
Posts: 10
Joined: Wed 20 Apr 2016 21:12

Cannot set Pooling on non-1433 port

Post by wkotze@wccsoft.co.za » Thu 30 Jun 2016 12:21

Hi
I have the strangest problem, and i cannot understand why,

if sqlserver set to standard port 1433 i am able to connect with pooling=true,
BUT
when i change to different port on sql server (same port opened on firewalll ),
i am unable to connect with pooling=true, I can however connect with pooling=false

running sdac 7.3.313 on seattle10, fmx app, VPS running mssql 2012 express on winserver2012
conn server, database,username, port and password is set, in addition
conn1.Options.Provider := msClasses.prDirect; //must use to connect for andoird, but give same problem prAauto on win32 fmx app anyway
conn1.Options.DisconnectedMode := true;
conn1.Options.LocalFailover := true;
conn1.options.AllowImplicitConnect := true;
conn1.Options.ApplicationName :='blahvlahblah';
dm.conn1.Pooling := true; // pooling min=0 max=100 clifetime=0 validate=false

AlexP
Devart Team
Posts: 5530
Joined: Tue 10 Aug 2010 11:35

Re: Cannot set Pooling on non-1433 port

Post by AlexP » Thu 30 Jun 2016 13:29

Hello,

Thank you for the information. We have reproduced and fixed the problem. This fix will be included to the next SDAC version.

wkotze@wccsoft.co.za
Posts: 10
Joined: Wed 20 Apr 2016 21:12

Re: Cannot set Pooling on non-1433 port

Post by wkotze@wccsoft.co.za » Thu 30 Jun 2016 14:35

Alex,
please elaborate as to what it is,
this has been driving me crazy for the last 2 days :)

AlexP
Devart Team
Posts: 5530
Joined: Tue 10 Aug 2010 11:35

Re: Cannot set Pooling on non-1433 port

Post by AlexP » Fri 01 Jul 2016 06:04

We can send you a night build in order for you to check this case on your sample. For this, please send your license number to alexp*devart*com.

wkotze@wccsoft.co.za
Posts: 10
Joined: Wed 20 Apr 2016 21:12

Re: Cannot set Pooling on non-1433 port

Post by wkotze@wccsoft.co.za » Thu 11 Aug 2016 22:06

Alex, any timeline as to when this will be released.
thanks
Wihan

AlexP
Devart Team
Posts: 5530
Joined: Tue 10 Aug 2010 11:35

Re: Cannot set Pooling on non-1433 port

Post by AlexP » Fri 12 Aug 2016 07:43

We plan to release the new version next month.

Post Reply