TMSConnection.OpenDataSets does not work with TMSQuery.Debug

Discussion of open issues, suggestions and bugs regarding SDAC (SQL Server Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
brace
Posts: 213
Joined: Wed 14 Feb 2007 08:26

TMSConnection.OpenDataSets does not work with TMSQuery.Debug

Post by brace » Wed 15 Jun 2016 16:40

If in a TMSQuery the Debug property is set to true when the dataset is opened with OpenDataSets the query before execution preview window does not appear, while it used to appear in past.

For example check this code:

Code: Select all

  MSQuery1.Debug := True;
  MSQuery1.Close;
if chkUseOpenDatasets.Checked then
begin
  MSConnection1.OpenDatasets([MSQuery1]);
  ShowMessage('The Preview won''t open');
end
else
begin
  MSQuery1.Open;
  ShowMessage('The Preview will open');
end;
Since i am almost 100% sure it was working in past (=opendatasets was triggering the preview) I want to ask whether this is a bug or a new behavior.

Please let me know. Thanks

ViktorV
Devart Team
Posts: 2299
Joined: Wed 30 Jul 2014 07:16

Re: TMSConnection.OpenDataSets does not work with TMSQuery.Debug

Post by ViktorV » Thu 16 Jun 2016 09:54

Thank you for the information. We will change this behavior of SDAC in one of the next builds.

brace
Posts: 213
Joined: Wed 14 Feb 2007 08:26

Re: TMSConnection.OpenDataSets does not work with TMSQuery.Debug

Post by brace » Mon 20 Jun 2016 12:39

ViktorV wrote:Thank you for the information. We will change this behavior of SDAC in one of the next builds.
Good to know you agree it must be modified, i hope this can be done in the next build.

azyk
Devart Team
Posts: 1057
Joined: Fri 11 Apr 2014 11:47
Location: Alpha Centauri A

Re: TMSConnection.OpenDataSets does not work with TMSQuery.Debug

Post by azyk » Tue 25 Apr 2017 06:05

This change was included in the SDAC 7.3.14 .

Post Reply