TMSLoader unspecified Error

Discussion of open issues, suggestions and bugs regarding SDAC (SQL Server Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
LHSoft
Posts: 104
Joined: Sat 18 Aug 2012 08:33

TMSLoader unspecified Error

Post by LHSoft » Sun 15 Jun 2014 14:43

Hello,

I have two tables on two different sqlservers, both with this declaration:

CREATE TABLE [dbo].[LanSites](
[nr] [int] IDENTITY(1,1) NOT NULL,
[Datei] [nvarchar](50) NULL,
[de] [ntext] NULL,
[cs] [ntext] NULL,
[ru] [ntext] NULL,
[en] [ntext] NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]

If trying to do loadfromDataset I get an "unspecified error"

I tried switching the Options, but no effect:

TbLoaderOLS.Close; TbLoaderOLS.TableName := 'LanSites';
MSLoader.TableName := 'LanSites';
//MSLoader.Options.LockTable := True;
//MSLoader.Options.KeepIdentity := True;
//MSLoader.Options.CheckConstraints := True;
LocalSQL.SQL.Clear;
LocalSQL.SQL.Add('delete from LanSites');
LocalSQL.Execute;
MSLoader.LoadFromDataSet(TbLoaderOLS);
Can you give me an idea whats wrong?

Best regards
Hans

LHSoft
Posts: 104
Joined: Sat 18 Aug 2012 08:33

Re: TMSLoader unspecified Error

Post by LHSoft » Mon 16 Jun 2014 16:35

Meanwhile I have changed the table to

Code: Select all

CREATE TABLE [dbo].[LanSites](
	[nr] [int] IDENTITY(1,1) NOT NULL,
	[Datei] [nvarchar](50) NULL,
	[de] [ntext] NULL,
	[cs] [ntext] NULL,
	[ru] [ntext] NULL,
	[en] [ntext] NULL,
 CONSTRAINT [PK_LanSites] PRIMARY KEY CLUSTERED 
(
	[nr] ASC
)WITH (PAD_INDEX  = OFF, STATISTICS_NORECOMPUTE  = OFF, IGNORE_DUP_KEY = OFF, ALLOW_ROW_LOCKS  = ON, ALLOW_PAGE_LOCKS  = ON) ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
same error.
But a similar table (autoincrement, PromaryKey, ntext) runs:

Code: Select all

CREATE TABLE [dbo].[MoKonZA](
	[nr] [int] IDENTITY(1,1) NOT NULL,
	[Sort] [int] NOT NULL,
	[ZaDE] [nvarchar](50) NULL,
	[ZaCS] [nvarchar](50) NULL,
	[ZaRU] [nvarchar](50) NULL,
	[ZaEN] [nvarchar](50) NULL,
	[nichtRegistriert] [bit] NULL,
	[Erstkontakt] [bit] NULL,
	[Karte] [bit] NULL,
	[noFrame] [bit] NULL,
	[Überweisung] [bit] NULL,
	[Nachnahme] [bit] NULL,
	[aktiv] [bit] NULL,
	[Ausland] [bit] NULL,
	[Vorauskasse] [bit] NULL,
	[Abholung] [bit] NULL,
	[Lastschrift] [bit] NULL,
	[Rabatt] [bit] NULL,
	[Land] [nvarchar](50) NULL,
	[Link] [nvarchar](150) NULL,
	[Image] [nvarchar](50) NULL,
	[InfoDE] [ntext] NULL,
	[InfoCS] [ntext] NULL,
	[InfoRU] [ntext] NULL,
	[InfoEN] [ntext] NULL,
	[TSpaymentType] [nvarchar](50) NULL,
	[Gebühr] [float] NOT NULL,
	[param_brand] [nvarchar](50) NULL,
	[param_pm] [nvarchar](50) NULL,
	[InfoLogo] [nvarchar](50) NULL,
	[InfoLogoLink] [nvarchar](150) NULL,
 CONSTRAINT [PK_MoKonZA] PRIMARY KEY CLUSTERED 
(
	[Sort] ASC
)WITH (PAD_INDEX  = OFF, STATISTICS_NORECOMPUTE  = OFF, IGNORE_DUP_KEY = OFF, ALLOW_ROW_LOCKS  = ON, ALLOW_PAGE_LOCKS  = ON) ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]

both with

Code: Select all

          
                MSLoader.Options.LockTable := True;
                MSLoader.Options.KeepIdentity := True;
                MSLoader.Options.CheckConstraints := True;
Best regards
Hans

azyk
Devart Team
Posts: 1057
Joined: Fri 11 Apr 2014 11:47
Location: Alpha Centauri A

Re: TMSLoader unspecified Error

Post by azyk » Tue 17 Jun 2014 13:21

Hello,

We couldn't reproduce the problem.
Please supply us with the following information:
- exact version of Microsoft SQL Server and OLE DB provider you use. You can learn it from the Info sheet of TMSConnection Editor;
- exact version of Delphi or C++ Builder;
- exact version of SDAC.

LHSoft
Posts: 104
Joined: Sat 18 Aug 2012 08:33

Re: TMSLoader unspecified Error

Post by LHSoft » Tue 17 Jun 2014 23:18

Hello,

the target SQLServer is Microsoft SQL Server Express Edition with Advanced Services (64-bit) v10.50.4000.0
Provider: Microsoft SQL Server Native Client 10.0: 10.50.4000.0
the source SQLServer is Microsoft SQL Server Enterprise Edition (64-bit) v10.50.2500.0

using DelphiXE5 update 2
SDAC 6.10.20

The source table is very busy

azyk
Devart Team
Posts: 1057
Joined: Fri 11 Apr 2014 11:47
Location: Alpha Centauri A

Re: TMSLoader unspecified Error

Post by azyk » Fri 20 Jun 2014 12:33

Hello,

Thank you for the information. We have reproduced this problem and fixed it. This fix will be included in the next SDAC build.

Post Reply