Property EncryptedPassword does not exist

Discussion of open issues, suggestions and bugs regarding SDAC (SQL Server Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
bherring1979
Posts: 2
Joined: Tue 10 Sep 2013 20:54

Property EncryptedPassword does not exist

Post by bherring1979 » Thu 03 Oct 2013 02:09

Since the newest version of SDAC was released, we get an error at runtime that says Property EncryptedPassword does not exist. "Exception EReadError in module rtl70.bpl Property EncryptedPassword does not exist" is the exact error that we get at run time. I see there was some stuff added to DBAcess.pas in this version for encrypted passwords. Is there anything O need to update in my project to fix this or can I omit the new features?

AlexP
Devart Team
Posts: 5530
Joined: Tue 10 Aug 2010 11:35

Re: Property EncryptedPassword does not exist

Post by AlexP » Thu 03 Oct 2013 12:37

Hello,

Most probably, you have old *.bpl, *.dcu, *.pas, etc., SDAC files remained. Please delete all the old files and try reinstalling SDAC once more.

m227
Posts: 59
Joined: Mon 06 Aug 2007 12:41

Re: Property EncryptedPassword does not exist

Post by m227 » Fri 06 Jun 2014 18:54

I had similar problem with MyDAC upgrade. Had to manually delete TMyConnection.EncryptedPassword line (from dfm file).

azyk
Devart Team
Posts: 1058
Joined: Fri 11 Apr 2014 11:47
Location: Alpha Centauri A

Re: Property EncryptedPassword does not exist

Post by azyk » Tue 10 Jun 2014 12:32

Hello,

Please clarify: do you use C++Builder?
Note: such error mustn't occur in Delphi.

m227
Posts: 59
Joined: Mon 06 Aug 2007 12:41

Re: Property EncryptedPassword does not exist

Post by m227 » Mon 21 Jul 2014 20:23

I've got it in Delphi XE2/Win 7/64, and still have problem in runtime. I tried to delete all relevant my*.* files from Program Files\Embarcadero\Rad Studio... (bpl, dcp and so on) and reinstall MyDAC with no success.

When I define password property for TMyConnection in Object Inspector i get this error in runtime. Now using MyDAC 8.3.8, version PRO.

hint: I've got 2 Delphis on single machine - D2006 and XE2, both has MyDac installed, but D2006 has 7.1 version.

I tried to uninstall and reinstall Component. But I succeed when I found in Program Files(x64)\Devart\ folder some subfolders:
MyDAC for RadStudio XE2
MyDAC for Delphi 2006
MyDAC

I renamed the last one (probably form previous installations) and problem fixed.

azyk
Devart Team
Posts: 1058
Joined: Fri 11 Apr 2014 11:47
Location: Alpha Centauri A

Re: Property EncryptedPassword does not exist

Post by azyk » Wed 23 Jul 2014 10:10

Thank you for the information. If there is anything else I can help you with, please contact me.

Post Reply