Parser error in new version

Discussion of open issues, suggestions and bugs regarding SDAC (SQL Server Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
Aufhauser
Posts: 56
Joined: Mon 21 Nov 2005 09:44
Location: Herzogenburg, Austria

Parser error in new version

Post by Aufhauser » Fri 20 Sep 2013 11:30

There is a bug in new version 6.8.15 using TMSQuery to select data from a view in a schema, with an name containing not englisch charakters e.g.
"SELECT * from Gföhl.ARB_TF"
The error message is "Parser: The unknown symbol 'ö' $00F6"
Version 6.7.14 works fine.

Thanks for helping
Stefan

AndreyZ

Re: Parser error in new version

Post by AndreyZ » Fri 20 Sep 2013 13:25

Thank you for the information. We have fixed this problem. This fix will be included in the next SDAC build.
As a temporary workaround, you can use quotation.

LHSoft
Posts: 104
Joined: Sat 18 Aug 2012 08:33

Re: Parser error in new version

Post by LHSoft » Fri 20 Sep 2013 15:20

Hello,

this seems to be the same as my errordescription in my post from today with problems in Indexfieldnames.

So it would be nice if you could publish a fix for that very soon, cause there are very many places in my software where this would cause problems.

Other solution is only to go back to last version, but there many problems too.

Hope you can help us soon.

best regards
Hans

AndreyZ

Re: Parser error in new version

Post by AndreyZ » Mon 23 Sep 2013 08:12

We will try to release all DAC products with the fix this week.

LHSoft
Posts: 104
Joined: Sat 18 Aug 2012 08:33

Re: Parser error in new version

Post by LHSoft » Mon 23 Sep 2013 16:17

thank you very much,

hans

AndreyZ

Re: Parser error in new version

Post by AndreyZ » Wed 25 Sep 2013 10:42

The new SDAC build 6.8.16 with the fix is already available.

Post Reply