Table valued parameters TDateTime field trim milisec

Discussion of open issues, suggestions and bugs regarding SDAC (SQL Server Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
Calkins
Posts: 10
Joined: Thu 12 Sep 2013 10:40

Table valued parameters TDateTime field trim milisec

Post by Calkins » Thu 12 Sep 2013 12:42

Hi.

In our version 6.6 when we pass TDateTime field (format 'YYYY-MM-DD hh:nn:ss.zzz') in TMSTableData it sends DateTime without miliseconds to database (checked in profiler).

Code: Select all

TMSStoredProc *mssp;
TMSTableData *mst;

 mst->Open();
 mst->Append();
 mst->FieldByName("BeginDate")->AsDateTime = TDateTime(2013,9,12,10,31,50,440);
 mst->Post();
 mssp->ParamByName("EventsComment")->AsTable = mst->Table;
 mssp->Execute();
 mst->Close();


Code above sends only 2013-09-12 10:31:50 without 440 miliseconds.

It is an bug or we did something wrong?

Thx in advance for help.
Damian

AndreyZ

Re: Table valued parameters TDateTime field trim milisec

Post by AndreyZ » Thu 12 Sep 2013 15:39

Hello,

Thank you for the information. We have reproduced the problem and the investigation of the problem is in progress. We will notify you when we have any results.

Calkins
Posts: 10
Joined: Thu 12 Sep 2013 10:40

Re: Table valued parameters TDateTime field trim milisec

Post by Calkins » Wed 18 Sep 2013 05:53

Hi.

Any news about this bug?

AndreyZ

Re: Table valued parameters TDateTime field trim milisec

Post by AndreyZ » Wed 18 Sep 2013 08:12

We are investigating this problem. As soon as we have any results we will let you know.

AndreyZ

Re: Table valued parameters TDateTime field trim milisec

Post by AndreyZ » Thu 19 Sep 2013 07:57

We have fixed this problem. This fix will be included in the next SDAC build.

Calkins
Posts: 10
Joined: Thu 12 Sep 2013 10:40

Re: Table valued parameters TDateTime field trim milisec

Post by Calkins » Thu 26 Sep 2013 08:34

Thx for your support.

AndreyZ

Re: Table valued parameters TDateTime field trim milisec

Post by AndreyZ » Thu 26 Sep 2013 10:31

This problem is fixed in SDAC 6.8.15. It is already available for download.

Post Reply