Delphi XE3 "Product or License Validation Error" after installing SDAC 6.7.14

Discussion of open issues, suggestions and bugs regarding SDAC (SQL Server Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
lcoelho
Posts: 47
Joined: Wed 13 Apr 2011 13:41

Delphi XE3 "Product or License Validation Error" after installing SDAC 6.7.14

Post by lcoelho » Mon 09 Sep 2013 14:11

Dear Sirs,

I've just installed the latest SDAC, namely 6.7.14, on Delphi XE3. After this, when I run a project in design mode, I get the following error from Ebarcadero:

Product or License Validation Error

Then Delphi closes.

Could you kindly assist with this? Thank you and kind regards

AndreyZ

Re: Delphi XE3 "Product or License Validation Error" after installing SDAC 6.7.14

Post by AndreyZ » Tue 10 Sep 2013 11:55

Hello,

Please make sure you have RAD Studio XE3 Update 2 installed. If you do but the problem persists, please write about this problem to the Embarcadero support.

lcoelho
Posts: 47
Joined: Wed 13 Apr 2011 13:41

Re: Delphi XE3 "Product or License Validation Error" after installing SDAC 6.7.14

Post by lcoelho » Tue 10 Sep 2013 12:45

Hi AndreyZ,

I do have RAD Studio XE3 Update 2 installed.

But why does the previous version of SDAC (6.7.13) not do this?

I'm working on a virtual machine and when a revert back to the SDAC 6.7.13, the problem doesn't happen. When I install SDAC 6.7.14 then it happens. Won't Embarcadero refer the problem back to you?

Please kindly check. Thank you and kind regards.

lcoelho
Posts: 47
Joined: Wed 13 Apr 2011 13:41

Re: Delphi XE3 "Product or License Validation Error" after installing SDAC 6.7.14

Post by lcoelho » Wed 11 Sep 2013 04:56

Hi AndreyZ,

Further to my last post, I found that different settings are placed in the registry when installing version 6.7.14 that aren't there with version 6.7.13, that could assist you. The settings are the following:

HKEY_CURRENT_USER\Software\Embarcadero\BDS\10.0\Known Packages\C:\Program Files (x86)\Embarcadero\RAD Studio\10.0\Bin\dcldac170.bpl=
HKEY_CURRENT_USER\Software\Embarcadero\BDS\10.0\Known Packages\C:\Program Files (x86)\Embarcadero\RAD Studio\10.0\Bin\dclcrcontrols170.bpl=
HKEY_CURRENT_USER\Software\Embarcadero\BDS\10.0\Known Packages\C:\Program Files (x86)\Embarcadero\RAD Studio\10.0\Bin\dclsdac170.bpl=
HKEY_CURRENT_USER\Software\Embarcadero\BDS\10.0\Known Packages\C:\Program Files (x86)\Embarcadero\RAD Studio\10.0\Bin\dclsdacfmx170.bpl=
HKEY_CURRENT_USER\Software\Embarcadero\BDS\10.0\Known Packages\C:\Program Files (x86)\Embarcadero\RAD Studio\10.0\Bin\DataSetManager170.bpl=

Thank you for your kind assistance with this. I have also contacted Embarcadero as suggested by you.

AndreyZ

Re: Delphi XE3 "Product or License Validation Error" after installing SDAC 6.7.14

Post by AndreyZ » Wed 11 Sep 2013 07:24

These packages are placed in the registry with both SDAC 6.7.14 and 6.7.13. That is a correct behaviour.
We cannot reproduce this problem. Please read the following article: http://support.embarcadero.com/article/40373 , and check all cases that are described in it.
We will consider changing our installation process to avoid copying our files to the Bin directory.

lcoelho
Posts: 47
Joined: Wed 13 Apr 2011 13:41

Re: Delphi XE3 "Product or License Validation Error" after installing SDAC 6.7.14

Post by lcoelho » Wed 11 Sep 2013 10:58

Hi AndreyZ,

I agree that both versions (6.7.13 and 6.7.14) point to the Embarcadero BIN folder. However, what is interesting is that with the 6.7.13 version installation, the way these entries are stored in the registry differ from how they are stored after 6.7.14.

In 6.7.13, they are stored as $(BDSBIN)\dcldac170.bpl, etc.
In 6.7.14, they are stored as C:\Program Files (x86)\Embarcadero\RAD Studio\10.0\Bin\dcldac170.bpl. (The actual path and not the path variable)

Could I add that I'm running Windows 8 64x bit.

In the meantime, please could you guide me on correcting the problem until you have changed the installation process to avoid copying your files to the Bin directory? Thank you for your kind assistance.

AndreyZ

Re: Delphi XE3 "Product or License Validation Error" after installing SDAC 6.7.14

Post by AndreyZ » Thu 12 Sep 2013 09:08

Please try the following:
- close Delphi XE3;
- open the registry editor;
- change paths to SDAC bpl files in the Known Packages section so they use the $(BDSBIN) variable instead of the actual path.
Does the problem persist after these steps?

lcoelho
Posts: 47
Joined: Wed 13 Apr 2011 13:41

Re: Delphi XE3 "Product or License Validation Error" after installing SDAC 6.7.14

Post by lcoelho » Thu 12 Sep 2013 13:31

Hi AndreyZ,

Thank you for your kind assistance with this problem.

I tried what you suggested:

I installed version 6.7.14 (I've tried first removing SDAC 6.7.13 and then installing 6.7.14 and also just upgrading without first installing 6.7.13). In the registry, renamed SDAC registered components from the full path to $(BDSBIN)\...

But the problem continues, as soon as I open a project and run it in the IDE, Delphi shuts down and the message appears.

AndreyZ

Re: Delphi XE3 "Product or License Validation Error" after installing SDAC 6.7.14

Post by AndreyZ » Fri 13 Sep 2013 08:20

Please try the following:
- install SDAC 6.7.14;
- open Delphi XE3;
- open Delphi main menu->Component->Install Packages and remove all packages that have the "Devart" string in their names;
- close Delphi XE3;
- remove *dac*170.bpl, *crcontrols*170.bpl, and *datasetmanager*170.bpl from the Bin and Bin64 directories of your Delphi XE3;
- open Delphi XE3;
- open Delphi main menu->Component->Install Packages and add the dclsdac170.bpl, dclcrcontrols170.bpl, and datasetmanager170.bpl packages from the SDAC_Install_Directory\Bin\Win32 directory.

lcoelho
Posts: 47
Joined: Wed 13 Apr 2011 13:41

Re: Delphi XE3 "Product or License Validation Error" after installing SDAC 6.7.14

Post by lcoelho » Mon 16 Sep 2013 04:37

Hi AndreyZ,

I have found the problem.

We have some in-house components that use SDAC. After installing a new version of SDAC, in this case it was 3.7.14, if you forget to recompile and install the components that use SDAC, then any projects that have the SDAC component, when run from the IDE, will cause the error mentioned.

Anyway, it would be good to have future versions of SDAC not place files and register components in the Embarcadero BIN anyway. We notice the other 3rd party vendors have not stored anything in the Embarcadero BIN.

Thank you for your kind assistance.

AndreyZ

Re: Delphi XE3 "Product or License Validation Error" after installing SDAC 6.7.14

Post by AndreyZ » Mon 16 Sep 2013 06:26

Thank you for the information. We will try to resolve this problem as soon as possible.

Post Reply