Problem in pinpointing an error

Discussion of open issues, suggestions and bugs regarding SDAC (SQL Server Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
brace
Posts: 213
Joined: Wed 14 Feb 2007 08:26

Problem in pinpointing an error

Post by brace » Thu 01 Aug 2013 12:52

hello.

My application sudden (=after a new release) started to give problems only on some machines. I cannot reproduce it on my developement machine.

It is probably an Exception fired somewhere in the SDAC code. The error users get is

Valori dei parametri di input non validi. Controllare i valori di stato per ulteriori dettagli.

By googling i foudn it is related to this:
http://support.microsoft.com/kb/949959

I tried with MadExcept but it seems not working with components code, so I would like to ask you what can cause this.
I am using 6.1.6 for RadStudio XE2.

THanks

brace
Posts: 213
Joined: Wed 14 Feb 2007 08:26

Re: Problem in pinpointing an error

Post by brace » Fri 02 Aug 2013 07:45

I found the problem. I solved by initializing a MSQUeery parameter on the BeforeOpen event.

Now my question is:
why the invalid parameters error occurs only on some machines?

AndreyZ

Re: Problem in pinpointing an error

Post by AndreyZ » Fri 02 Aug 2013 09:35

Please try creating a small sample that demonstrates the problem and send it to andreyz*devart.com , including a script to create all needed server objects (tables, stored procedures, etc.). Also please specify the exact version of SQL Server server and client you are using. You can learn it from the Info sheet of TMSConnection Editor.

Post Reply