Problems after reinstallation fmx163.bpl not found

Discussion of open issues, suggestions and bugs regarding SDAC (SQL Server Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
brace
Posts: 213
Joined: Wed 14 Feb 2007 08:26

Problems after reinstallation fmx163.bpl not found

Post by brace » Wed 03 Oct 2012 09:47

Hello,

I had to format my machine and reinstall Delphi XE2 from scratch.

Anyway after installing latst SDAC (6.5.9) for XE2 as I run Delphi i have this error:
(i try to translate it in english):
---------------------------
bds.exe - System Error
---------------------------
Impossibile to start the software since fmx163.bpl is not found on this computer. To solve the problem try to reinstall the software.

after clicking ok i immediately get:
[Window Title]
Error

[Content]
Can't load package C:\Program Files (x86)\Embarcadero\RAD Studio\9.0\Bin\dclsdac160.bpl.
Impossibile trovare il modulo specificato.
Do you want to attempt to load this package the next time a project is loaded?

Please help me, I am stuck!
If I try to crate a new VCL forms app project in Delphi I get the same 2 messages.
Thanks.

AlexP
Devart Team
Posts: 5530
Joined: Tue 10 Aug 2010 11:35

Re: Problems after reinstallation fmx163.bpl not found

Post by AlexP » Wed 03 Oct 2012 13:45

hello,

Make sure you have installed the latest version of RAD Studio XE2 update 4 hotfix 1, and selected FMX packages installation, when installing RAD Studio, since our components require FMX packages.

brace
Posts: 213
Joined: Wed 14 Feb 2007 08:26

Re: Problems after reinstallation fmx163.bpl not found

Post by brace » Wed 03 Oct 2012 21:52

Hello,

i have Embarcadero® RAD Studio XE2 Version 16.0.4429.46931

I don't see Hotfix 1.

I installed with default settings so i didn't uncheck fmx.

Anyway after installing Delphi I did check for updates and it foudn onny Help update 6, no hotfixes, please suggest what to do.

AlexP
Devart Team
Posts: 5530
Joined: Tue 10 Aug 2010 11:35

Re: Problems after reinstallation fmx163.bpl not found

Post by AlexP » Thu 04 Oct 2012 06:37

hello,

If you use Delphi XE2 Update 4 without HotFix 1, you can use only the following versions of SDAC: 6.1.5 or 6.1.6,
For using later versions of SDAC, you need to install HotFix 1 for Delphi, this requirement is specified at our website in the Compatibility section
http://www.devart.com/sdac/compatibility.html

brace
Posts: 213
Joined: Wed 14 Feb 2007 08:26

Re: Problems after reinstallation fmx163.bpl not found

Post by brace » Fri 05 Oct 2012 09:04

Thanks for the reply.

I installed 6.1.6 as suggested and i was able to run xe2 with no errors this time.

Anyway according to this: https://forums.embarcadero.com/thread.j ... adID=76115

I have update 5 hotfix 1 (since my build number is 16.0.4429.46931), and on that post they say that "Hotfix 1" doesn't show up in the aboutbox.

Anyway I am no 100% sure but one week ago i installed XE2 and Is saw "hotfix 1" in about box.

I hope now I can work, all these problems with Delphi versions is worse than annoying...

Thanks.

AlexP
Devart Team
Posts: 5530
Joined: Tue 10 Aug 2010 11:35

Re: Problems after reinstallation fmx163.bpl not found

Post by AlexP » Fri 05 Oct 2012 10:38

hello,

The specified number of build 16.0.4429.46931 matches RAD Studio XE2 Update 4. To use the latest versions of our products, you should download and install Hotfix 1 from the official Embarcadero web-site: http://edn.embarcadero.com/article/42282

brace
Posts: 213
Joined: Wed 14 Feb 2007 08:26

Re: Problems after reinstallation fmx163.bpl not found

Post by brace » Fri 05 Oct 2012 11:27

ok, thanks for the clarification.

FOr now I succeded with 6.1.6 and i am trying to solve (probably similar) problems with other 3rd party compoennts.

Post Reply