Problem with build 54

Discussion of open issues, suggestions and bugs regarding SDAC (SQL Server Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
Romano
Posts: 41
Joined: Tue 10 Feb 2009 11:21

Problem with build 54

Post by Romano » Sun 06 Dec 2009 19:49

Hi,
I have problem with build 54. If I use this construction:

Code: Select all

RAISERROR 50000 'xx'
SELECT 1
I get assert on

procedure TOLEDBCommand.Execute(Iters: integer = 1);
...
var
IUnk: IUnknown;
begin
Assert(FIUnknown = nil); <---- HERE
...

In build 52 was all OK.

And sometimes (I still don't know in which case) I get new connection (the second SPID in the same application). Again - in build 52 was all OK...

Thanks
Roman

Dimon
Devart Team
Posts: 2885
Joined: Mon 05 Mar 2007 16:32

Post by Dimon » Mon 07 Dec 2009 08:29

I can not reproduce the problem.
Please send me a complete small sample to dmitryg*devart*com to demonstrate it.

Romano
Posts: 41
Joined: Tue 10 Feb 2009 11:21

Post by Romano » Fri 11 Dec 2009 09:01

Hi,
you have a mail. Let me know please that you get it.

Thanks
Romano

Dimon
Devart Team
Posts: 2885
Joined: Mon 05 Mar 2007 16:32

Post by Dimon » Fri 11 Dec 2009 10:41

Thank you for information. We have reproduced this problem and fixed it. This fix will be included in the next SDAC build.
As a temporary solution you should use the Open method instead of Execute.

Romano
Posts: 41
Joined: Tue 10 Feb 2009 11:21

Post by Romano » Mon 25 Jan 2010 14:24

Hi,
where do you plan to release next SDAC build?

Thanks
Romano

Dimon
Devart Team
Posts: 2885
Joined: Mon 05 Mar 2007 16:32

Post by Dimon » Mon 25 Jan 2010 15:00

The next SDAC build will be released in the course of this week.

Post Reply