Behavior of Filter and Findfirst

Discussion of open issues, suggestions and bugs regarding SDAC (SQL Server Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
Posts: 2
Joined: Tue 12 Jun 2007 11:45

Behavior of Filter and Findfirst

Post by PeterCH » Tue 07 Aug 2007 08:37

In SDAC, also in 3.8.x this worked:

1. Load a RecordSet in TMSQuery
2. Set the Filter to a specific value (eg: "ID=100")
3. Call the "FindFirst" Method witch positioned the
recordset to the first record matching the filter

Please note that one was not required to
set the filtered property to enable !

In SDAC this is not working anymore.

Unfortunately some developers used this method
often in our source code so we would be very glad
if we could find a workaround for this problem.

Posts: 1693
Joined: Thu 28 Oct 2004 13:56

Post by Ikar » Tue 07 Aug 2007 15:43

Thank you for information.
We have reproduced the problem and fixed it.
This fix will be included in the next build of SDAC.

Posts: 2
Joined: Fri 10 Aug 2007 13:37

Post by chedom » Wed 19 Sep 2007 08:14

I have a same problem in version Is there a workaround for this problem?

Posts: 2098
Joined: Tue 14 Feb 2006 10:14

Post by Antaeus » Wed 19 Sep 2007 08:35

In a couple of days we will release the new build of SDAC which will include fix to this problem.

Post Reply