Page 1 of 1

xbase/VFP - Memo field

Posted: Tue 05 Nov 2019 17:36
by halsdk
Hopefully someone can help me- Devart tech support has apparently given up and is no longer responding. Submitted a support ticket and work

My problem is that if I query (From SQL Openquery) a Foxpro table (.dbf) that contains an empty memo field the query returns an error that the data.

An unexpected NULL value was returned for column "[MSDASQL].MEMO1" from OLE DB provider "MSDASQL" for linked server "TEST". This column cannot be NULL.

If I add text to the memo field, it still doesn't work as I get an error:
Cannot get the current row value of column "[MSDASQL].MEMO1" from OLE DB provider "MSDASQL" for linked server "TEST". The provider cannot allocate memory or open another storage object on this column.

So basically, my problem is that I cannot include memo fields in a query which is one of the main reason for purchasing the odbc driver.

Can anyone provide assistance?

Re: xbase/VFP - Memo field

Posted: Mon 11 Nov 2019 15:11
by Stellar
Thank you for the information.
We fixed the DBF tables locking issue, as well as the issue with reading data from tables that contain Memo fields in MSSMS.
The fixes will be included in the next ODBC Driver for xBase build.

As a workaround, we can provide you with a nightly build of ODBC Driver for xBase.
For this, you should send the appropriate request via the e-support form. ( the "Support"\"Request Support" menu)

Re: xbase/VFP - Memo field

Posted: Mon 11 Nov 2019 15:54
by halsdk
Received the link for the nightly build (Nov 6). Installed but none of the issues I am having are resolved.

So still the same 2 issues:
1- Cannot query a table where the result includes a memo field that is empty
2- Cannot query a table if any other table is open in that same folder- Not just the table being queried, but ANY table.

Re: xbase/VFP - Memo field

Posted: Wed 13 Nov 2019 11:25
by Stellar
We've replied to your ticket in E-Support, please check your inbox.