Zoho CRM ODBC with MS Access

Discussion of open issues, suggestions and bugs regarding usage of ODBC Drivers
Post Reply
rocketraman
Posts: 1
Joined: Thu 14 Feb 2019 21:07

Zoho CRM ODBC with MS Access

Post by rocketraman » Thu 14 Feb 2019 21:25

Trying to link tables using the Zoho CRM ODBC driver with MS Access 2016. I get the message "ODBC-Call Failed" (sometimes), but whether or not the ODBC Failed message comes up, Access always shows the rows in the table with every value showing "#Deleted".

I tried the same connection with Excel, and am able to pull data into Excel.

Having researched this, it looks like this happens when Access tries to stuff an Id / primary key value into a column which is too small, or when the value stored by Access does not match the value stored in the backend. See:

* https://stackoverflow.com/questions/966 ... as-deleted
* https://dba.stackexchange.com/questions ... rough-odbc

The ID values coming back from the driver look like this: 2914909000000136011.

Using a "local table" works, but not a linked table -- the local table is ok for queries, but obviously won't work well for any type of updating.

Anyone have a solution for this failure of Access to properly link to Zoho CRM data via the ODBC driver?

MaximG
Devart Team
Posts: 1375
Joined: Mon 06 Jul 2015 11:34

Re: Zoho CRM ODBC with MS Access

Post by MaximG » Fri 15 Feb 2019 15:48

The behavior you described is a functional peculiarity of Microsoft Access and we cannot change it.

jlescano
Posts: 1
Joined: Tue 23 Apr 2019 19:34

Re: Zoho CRM ODBC with MS Access

Post by jlescano » Tue 23 Apr 2019 21:30

I managed to get past this problem by activating the "Support Large Number (Bigint) datatype for linked/imported tables" in MS Access Options - Current Database. I am using MS for Office 365 32bits, latest patch.

Now, when I link all tables, I get an error in some of them:
• Contacts / Leads ERROR: [DEVART][ODBC][Zoho CRM] Zoho Native Type 'consent lookup' (#2)
• Data_Subject_Requests ERROR: [DEVART][ODBC][Zoho CRM] Object 'Data_Subject_Requests' does not have field 'Owner' (#2)
• Solutions ERROR: [DEVART][ODBC][Zoho CRM] Object 'Solutions' does not have field 'Product' (#2)

Past that point, I face a new problem: while some tables (e.g. User, Activities) work perfectly, when trying to open other tables I get the message “ODBC—Call Failed” and MS Access displays "#Name?" in all fields:
• ACCOUNT NOTES
• ACCOUNTS
• ACTIVITY NOTES
• DEALS
• NOTES
• PROFILES
• ROLES

As in the case reported in the previous post, if I make them Local tables the problem is over, but so is the ability to update from MS Access.

Is this a bug? Any idea how to resolve these problems?
Thanks a lot.

MaximG
Devart Team
Posts: 1375
Joined: Mon 06 Jul 2015 11:34

Re: Zoho CRM ODBC with MS Access

Post by MaximG » Thu 25 Apr 2019 14:22

We have fixed the issue related to the occurrence of the "#Name?" value in all fields. As a temporary workaround, we can provide you with a night build of our product. For this, please specify your license number via the e-support form ( https://www.devart.com/company/contactform.html ).
Please also specify in detail the steps for reproducing the issue related to the work of the Contacts /Leads linked tables.

Post Reply