Error unrecognized configuration parameter "autocommit" when try connect with PostgreSQL 9.5.7 X64 on Windows

Discussion of open issues, suggestions and bugs regarding EntityDAC
Post Reply
niton_dev
Posts: 18
Joined: Thu 22 Jul 2010 14:44

Error unrecognized configuration parameter "autocommit" when try connect with PostgreSQL 9.5.7 X64 on Windows

Post by niton_dev » Sat 20 May 2017 10:16

Using last version of Entity Developer, I get error "Error unrecognized configuration parameter "autocommit"" when i try connect with PostgreSQL 9.5.7 X64 on Windows.

According with https://www.postgresql.org/docs/9.5/sta ... e-9-5.html, autocommit paramater was removed from PostgreSQL.

AlexP
Devart Team
Posts: 5530
Joined: Tue 10 Aug 2010 11:35

Re: Error unrecognized configuration parameter "autocommit" when try connect with PostgreSQL 9.5.7 X64 on Windows

Post by AlexP » Wed 24 May 2017 08:45

Hello,

We could not reproduce the problem on the latest EntityDAC 6.1.12 version, EntityDeveloper 9.9.999, and the specified PostgreSQL version. Please specify the exact EntityDAC, EntityDeveloper versions, also provide the connection string.

P.S. In addition, specify what EntityDeveloper you are using: distributed with EntityDAC or a separate one. And what .NET provider you are using.

niton_dev
Posts: 18
Joined: Thu 22 Jul 2010 14:44

Re: Error unrecognized configuration parameter "autocommit" when try connect with PostgreSQL 9.5.7 X64 on Windows

Post by niton_dev » Thu 25 May 2017 20:39

Sorry, I realized that I ran the test with an older version of the developer entity that was installed in another directory on my PC. Thank you for your support.

AlexP
Devart Team
Posts: 5530
Joined: Tue 10 Aug 2010 11:35

Re: Error unrecognized configuration parameter "autocommit" when try connect with PostgreSQL 9.5.7 X64 on Windows

Post by AlexP » Tue 30 May 2017 05:29

Hello,

You are welcome. Feel free to contact us if you have any further questions.

jeboersema
Posts: 3
Joined: Sat 25 Nov 2017 12:11

Re: Error unrecognized configuration parameter "autocommit" when try connect with PostgreSQL 9.5.7 X64 on Windows

Post by jeboersema » Sat 25 Nov 2017 12:16

I have just downloaded the Trial of EntityDac Professional and when trying to connect to a PostgreSQL 9.6 database I get the unrecognized configuration parameter "autocommit" error.

I see that the PostgreSQL driver shipped with the Trial is version 7.2

AlexP
Devart Team
Posts: 5530
Joined: Tue 10 Aug 2010 11:35

Re: Error unrecognized configuration parameter "autocommit" when try connect with PostgreSQL 9.5.7 X64 on Windows

Post by AlexP » Mon 27 Nov 2017 07:57

Hello,

We have already fixed the problem, and we can send you a night build in order for you to check this case on your sample.

Post Reply