dbForge error running a DO $$ command

Discussion of open issues, suggestions and bugs regarding database management and development tools for PostgreSQL
Post Reply
Posts: 1
Joined: Sat 16 May 2020 03:31

dbForge error running a DO $$ command

Post by stary » Sat 16 May 2020 04:05

I am just testing dbForge Studio for Postgres to replace my old PgAdmin 3.

I like it, but I wonder why do I get an error
cannot insert multiple commands into a prepared statement
if I run some code using the "DO" command block?

Here is a sample code that runs from PgAdmin and dbFiddle with no problem:

https://dbfiddle.uk/?rdbms=postgres_9.6 ... c9038eabe0

But when I run it from the dbForge Studio, the error occurs.

Posts: 15
Joined: Fri 27 May 2016 12:49
Location: Devart

Re: dbForge error running a DO $$ command

Post by YuriP » Sun 17 May 2020 12:10

We will fix this bug in the next version of Studio.

Also you could use $plpgsql$ or $sql$ instead of $$.
In this case you could use code highlights and code completion in plpgsql blocks, functions etc.

Post Reply