Unicode in Delphi 10.4

Discussion of open issues, suggestions and bugs regarding ODAC (Oracle Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
Posts: 1
Joined: Tue 23 Feb 2021 13:08

Unicode in Delphi 10.4

Post by HenrikL » Tue 23 Feb 2021 13:33


I have a problem to display Unicode (Cyrillic) symbols in Delphi 10.4. I can only see some strange symbols.

I am using Win10 + Delphi 10.4 + ODAC 11.3.2 for Delphi 10.4 + Oracle 11.
All the fields I use are TWideStringField. In the DB I use VARCHAR2 fields. I have configured the following TOraSession properties (I have tried turning each of them on and off):
Session.Options.UnicodeEnvironment := True;
Session.Options.UseUnicode := True;
Session.Options.Direct:= True;

In older versions of ODAC and Delphi, the code has worked, but I'm not sure since which version it stopped working. Are there any new properties I need to set? I tried to set a Charset as well, but it doen't work.

Devart Team
Posts: 1633
Joined: Mon 06 Jul 2015 11:34

Re: Unicode in Delphi 10.4

Post by MaximG » Tue 23 Feb 2021 15:12

To investigate the issue, please explain:

- what NLS parameters the used Oracle 11g has (in order for you to get them, use the following query : select * from v$nls_parameters )
- provide the sample via the e-support form https://www.devart.com/company/contactform.html

Post Reply