Page 1 of 1

Check-in Policy broken for VS2013?

Posted: Thu 10 Jul 2014 13:08
by willapp
Our company is currently evaluating Review Assistant for our development team. We are using Visual Studio 2013 Professional and TFS 2013.

So far the product looks very promising but we don't seem to be able to get the check-in policy working. I followed the instructions here ... oject.html but the "Pre commit code review" policy does not appear in the list.

I checked the registry key was correct at HKLM\SOFTWARE\Microsoft\VisualStudio\12.0\TeamFoundation\SourceControl\Checkin Policies and the key and path are both correct as per the "Registering Custom Policy" section here ... art-1.html but the policy still doesn't appear on the list.

I also tried (per another article I found elsewhere online) using the HKCU hive instead:

HKCU\Software\Microsoft\VisualStudio\12.0_Config\TeamFoundation\SourceControl\Checkin Policies

And adding the same key. This *does* make the policy appear on the list, but when I try and add it an error is shown "Error loading the Pre-Commit Code Review policy (The policy assembly 'Devart.ReviewAssistant.TeamFoundation, Version=, Culture=neutral, PublicKeyToken=09af7300eec23701' is not registered).

Are there any suggestions to get this working? I have tried removing and re-installing Review Assistant (full install with all options checked), and rebooted but nothing seems to make it work.

Re: Check-in Policy broken for VS2013?

Posted: Mon 14 Jul 2014 08:59
by AlexeyN
We have problem with registering TFS checkin policy at x64 machines. Please revert all your changes and install Review Assistant.

The installator writes the value to the x64 registry branch while Visual Studio attempts to read it from x86 branch. To solve your issue, please copy the registry key to the x86 registry branch.

To do this, please close all opened registry editors, run x86 one (e.g. run 'C:\Windows\SysWOW64\regedit.exe'), navigate to the 'HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\12.0\TeamFoundation\SourceControl\Checkin Policies' branch , create a new string value named 'Devart.ReviewAssistant.TeamFoundation' with the value 'C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\\Extensions\Devart\Review Assistant\Devart.ReviewAssistant.TeamFoundation.dll'.

Visual Studio does not add a new TFS check-in policy when you manually register it to the registry. To apply the newly added policies, you should close all Visual Studio instances, touch the "C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\Extensions\extensions.configurationchanged" file and run Visual Studio.

Re: Check-in Policy broken for VS2013?

Posted: Fri 27 Feb 2015 12:41
by AlexeyN
That problem was solved, so now Review Assistant properly writes the check-in policy settings into the x86 registry.

If you experience any issues, please refer to this topic. After setting up the policy, please refer to this help entry.

Re: Check-in Policy broken for VS2013?

Posted: Thu 19 Mar 2015 16:32
by DBolin
We recently installed Review Assistant and the Check-in policy was not working. The installer is writing to the correct x86 registry node but the path was incorrect. There were two \\ after IDE. After using the correct path the Check-in policy worked as expected.

Changed value FROM: C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\\Extensions\Devart\Review Assistant\Devart.ReviewAssistant.TeamFoundation.dll

TO: 'C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\Extensions\Devart\Review Assistant\Devart.ReviewAssistant.TeamFoundation.dll'.

Re: Check-in Policy broken for VS2013?

Posted: Fri 20 Mar 2015 11:16
by AlexeyN
Thank you for reporting the problem. We will investigate it ASAP.