Problems configuring Review Assistant...

Discussion of open issues, suggestions and bugs regarding code review tool for Visual Studio – Review Assistant
Post Reply
tww553
Posts: 2
Joined: Thu 23 May 2013 15:32

Problems configuring Review Assistant...

Post by tww553 » Tue 28 May 2013 12:07

We have been trying to evaluate Review Assistant, but have run into a basic configuration problem.

Here's our workflow: All our programmers (less than 10) work remotely from various locations around the United States. Our source code is kept in several remote Git repositories stored on a Git web hosting service called Assembla. (Assembla is similar to GitHub.) Each programmer uses Git on their local machine to access cloned local repositories of the source on Assembla. Each programmer uses Visual Studio 2012 to do his/her development using the local source files, committing to their local Git repositories often during the day. Each programmer periodically pushes their local commits to the remote repository on Assembla and pulls down the other programmer's commits.

Here's what we've tried so far: We installed Review Assistant server on a Windows machine in our company's main office and mapped a remote port number to internal port 85. We set up a single Review Assistant project, indicating Git was the source control system. We installed Review Assistant client on each programmer computer and can successfully log into the Review Assistant server from each. On each programmer machine, we've specified the correct PATH variable for Git: "C:\Program Files (x86)\Git\bin". This path is the same on all programmer machines. However, a problem arises with the Repository specification inside the project specification. When Git is chosen as the "Type", it appears like all programmers must specify the same "Working Directory". Different programmers have cloned their local Git repositories into differently named folder trees.

Does Review Assistant REQUIRE that the Git source code repositories all exist on a central LAN and all programmers must be connected to that LAN and be using the centralized repositories (as opposed to local repositories). Is there any way we can use Review Assistant in our workflow configuration?

I just realized as I was typing this, we might be able to have each programmer set up a local file system "share" name and map that to the same drive letter (such as "X:"), but do we really have to jump through those kind of hoops in order to use Review Assistant?

AlexeyN
Devart Team
Posts: 244
Joined: Wed 12 Sep 2012 12:09

Re: Problems configuring Review Assistant...

Post by AlexeyN » Tue 28 May 2013 16:20

Any user can overwrite the "Working directory" option in their client, i.e. everyone can specify here the path to the folder with their working directory
http://www.devart.com/review-assistant/ ... setup.html

tww553
Posts: 2
Joined: Thu 23 May 2013 15:32

Re: Problems configuring Review Assistant...

Post by tww553 » Wed 29 May 2013 17:57

Thanks for your timely response. I must have done something incorrect when I initially configured the server or the project, because going back and redoing it from scratch now allows each programmer to set their own local paths to their Git repositories.

I just want to clarify for future readers of this post that the error was mine and was NOT the fault of the Review Assistant software.

lex
Posts: 2
Joined: Fri 11 Oct 2013 16:54

Re: Problems configuring Review Assistant...

Post by lex » Fri 11 Oct 2013 17:01

Even though each user can override the working directory in the project setting it doesn't seem to properly apply to the file links in the comments. E.g. I have my code under
c:\Dev\proj\
and another developer has it under:
c:\Work\proj2\

When he selects a revision and adds a comment the link to the file appears with HIS url (c:\Work\proj2). When I click on it, I get error: "Version Control Access error. c:\Dev\proj\". Which means I cannot see any comments within the code that he just added.

What could we be configuring incorrectly?

Also, how do you handle branches during reviews? Do I have to switch to the same branch that another developer was using for review?

What about the pull request into the master branch? I suppose I need to be on the master branch and select the revision that was part of the pull request?

Thank you.

AlexeyN
Devart Team
Posts: 244
Joined: Wed 12 Sep 2012 12:09

Re: Problems configuring Review Assistant...

Post by AlexeyN » Mon 14 Oct 2013 14:59

What versions of Review Assistant and VCS do you use? We have just tested - and everything works fine.

You should have files in your local repository to see them. So, after you "pull" changes, you will be able to see the files with comments at the revision/branch, where they were created. It is not necessary to switch to the same branch.

lex
Posts: 2
Joined: Fri 11 Oct 2013 16:54

Re: Problems configuring Review Assistant...

Post by lex » Thu 17 Oct 2013 15:01

I just updated the Review Assistant to the latest one 2.0.130 and the problem still persists. I use Git (git version 1.8.1.msysgit.1). The repository is synchronized with the server.
When I hover over the comment section on the file name that my colleague has reviewed the file path maps to the location on his drive and clicking on it gives me the error described since my working directory is different than his. Basically if I comment on a file I can see changes but if the other person tries to open the file that was commented on they cannot, even though they can see the actual comment entry in the review.

Is there a particular order in terms of how the working directories need to be configured?

Thanks

AlexeyN
Devart Team
Posts: 244
Joined: Wed 12 Sep 2012 12:09

Re: Problems configuring Review Assistant...

Post by AlexeyN » Thu 17 Oct 2013 15:52

We need more information about the issue for further investigation.
Please contact us via our support page:

http://www.devart.com/company/contactfo ... -assistant

and send us the following screenshots:
  • With your project settings.
    With the tooltip with the incorrect path.
    With the review, that the comment belongs to.
    With the error, that appears when you try to open the file.

josh.white
Posts: 3
Joined: Mon 06 Nov 2017 09:52

Re: Problems configuring Review Assistant...

Post by josh.white » Tue 12 Nov 2019 12:20

Hi,

We've moved our source control to git and are having the same issue as above (file comparisons throwing error re local workspace).

What was the resolution to this?

ekaterinag
Devart Team
Posts: 9
Joined: Wed 06 Nov 2019 06:48

Re: Problems configuring Review Assistant...

Post by ekaterinag » Wed 13 Nov 2019 07:55

Josh hi,

Thank you for reaching out to us.

Please provide more information about the issue you are facing now to our support team: https://www.devart.com/company/contactform.html

Here is a list of the required screenshots:

- your project settings.
- the tooltip with the incorrect path.
- the review, that the comment belongs to.
- the error, that appears when you try to open the file.

Looking forward to receiving a ticket from you.

Best regards,

Kate Gondarovskaya
Devart Team
www.devart.com

Post Reply