precompiled dcu files

Discussion of open issues, suggestions and bugs regarding LiteDAC (SQLite Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
dudulajac
Posts: 5
Joined: Sat 25 Jun 2016 06:31

precompiled dcu files

Post by dudulajac » Wed 22 Nov 2017 11:06

Although I intend to switch to latest Delphi and probably latest UniDAC, I have a question related to compiler incompatibility version. For example while compiling application using UniDAC SQLite provider, an error: Unit LiteStaticUni was compiled with a different version of LiteCallUni.pSQLite3 emerged.
My Delphi is XE5 (compiler version 26) and LiteStaticUni.dcu files provided with UniDAC5.2.5 are at most for compiler version 19.
Does it mean I should switch to new version of UniDAC witch should include precompiled units that includes version 26.
Question is general in essence- this was just an example.

Thanks

MaximG
Devart Team
Posts: 1030
Joined: Mon 06 Jul 2015 11:34

Re: precompiled dcu files

Post by MaximG » Thu 23 Nov 2017 14:23

LiteCallUni module is distributed in UniDAC in the compiled form for all supported IDEs and platforms. You can see this by opening the folder with the installed UniDAC. Support for RAD Studio 10.2 Tokyo appeared in UniDAC 7.0.1 (05-Apr-17)

dudulajac
Posts: 5
Joined: Sat 25 Jun 2016 06:31

Re: precompiled dcu files

Post by dudulajac » Thu 23 Nov 2017 15:05

It is LiteStaticUni.dcu file in fact (not LiteCallUni) and in my folder I only have it for compiler versions of number 19 the most ie. ...\UniDAC\Lib\Delphi19\Win32 (I am working with XE5- compiler version 26).
You've said for all "supported" platforms. Does it mean if I purchase the newest UniDAC version, it will not work for some compiler (Delphi) version witch will emerge for example 2 years later (because of .dcu' s that couldn't be obviously compiled with compiler versions yet to come) ?

Thanks

MaximG
Devart Team
Posts: 1030
Joined: Mon 06 Jul 2015 11:34

Re: precompiled dcu files

Post by MaximG » Fri 24 Nov 2017 15:26

You are absolutely right. To install UniDAC (or any other Devart DAC product) you need a version that supports the required IDE. It does not depend on the version of LiteStaticUni,
LiteCallUni or some other library. By purchasing a subscription to our product, you get the possibility to work with any version of IDE supported at the time of the subscription, and also with any IDE released during the subscription period. Please note that renewing the subscription is significantly cheaper than purchasing a new version of our product:
https://www.devart.com/unidac/ordering.html("Renewals & Upgrades" tab)

Post Reply