Problems using UniDirect in VS2005

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for universal data access
Post Reply
aducom
Posts: 5
Joined: Tue 07 Nov 2006 13:24

Problems using UniDirect in VS2005

Post by aducom » Tue 07 Nov 2006 13:32

I'm currently evaluating some solutions for a database independent solution for Chrome (.Net object pascal solution of RemObjects) using the VS2005 environment. I have installed the beta and the components are appearing just fine. When adding a dataconnection the following message appears

Package Load Failure

Package 'UniDirect .Net Package' has failed to load properly (GUID={..}). Please contact vendor for assistance. Application restart is recommended, due to possible environment corruption. Would you like to disable loading this package in the future? You may use 'devenv/resetskippksgs' to re-enable package loading'.

Any clues?

tnx. Albert Drent
aducom software

Alexey
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Post by Alexey » Tue 07 Nov 2006 16:34

What edition of Visual Studio do you have?
Do you have VSIP installed?
Does this problem occur when you choose another project language?

aducom
Posts: 5
Joined: Tue 07 Nov 2006 13:24

Post by aducom » Tue 07 Nov 2006 19:01

Microsoft Visual Studio 2005
Version 8.0.50727.42 (RTM.050727-4200)
Microsoft .NET Framework
Version 2.0.50727

Installed Edition: IDE Standard

DPack 2.5.5
DPack for Visual Studio .NET. Copyright © 2004-2006 USysWare, Inc.
Please visit http://www.usysware.com/dpack/ for more information or contact us at support@usysware.com.

RemObjects Chrome for .NET 1.5.5.333
RemObjects Chrome. Copyright 2003-2006 RemObjects Software, Inc. All rights reserved. http://www.remobjects.com.
Full license for Albert Drent (a.drent@aducom.com).

RemObjects Client SDK 4.0 for .NET 4.0.11.509
RemObjects Client SDK 4.0 for .NET.
Copyright 2002-2006 RemObjects Software, LLC. All rights reserved. http://www.remobjects.com/ro.

RemObjects Everwood for .NET 1.0.1.73
RemObjects Everwood for .NET. Copyright 2003-2006 RemObjects Software, LLC. All rights reserved. http://www.remobjects.com.

I don't know what VSIP is. I don't have other languages installed.

albert

Alexey
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Post by Alexey » Wed 08 Nov 2006 07:20

You mean there are no C#, Visual Basic, etc. in your Visual Studio?

aducom
Posts: 5
Joined: Tue 07 Nov 2006 13:24

Post by aducom » Wed 08 Nov 2006 08:44

That's correct. I only have VS2005 with Chrome and no VB or C#. But I'm running the licenced version of VS2005, and actually using all kind of components written in .net languages like C#. They all work well... (The power of .Net is that you can develop in all kind of languages, it would be odd if your product dll would depend on the existance of any other languages? Other competative products seem to work well, but I'm still investigating.)

Alexey
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Post by Alexey » Wed 08 Nov 2006 09:03

I know. The question about languages was just my curiosity.
The actual problem is that current version of UniDirect .NET doesn't fully support Standard Edition of Visual Studio. But the problem you experience was supposed to happen only when using DDEX (e.g., when adding data source to the project, etc.), not when adding UniConnection component onto a form. So could you clarify under what circumstances the error occur?

aducom
Posts: 5
Joined: Tue 07 Nov 2006 13:24

Post by aducom » Wed 08 Nov 2006 13:51

Exactly as you describe. Putting the components on the form works, but as soon as I want to create a datasource the crash occurs. Problem is that I cannot create any (other) datasource w.o. this message.

Can you tell me someting about licencing? I some newsgroups I hear something about the need of deploying licence files?

Alexey
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Post by Alexey » Wed 08 Nov 2006 14:34

This problem has nothing to do with the licensing.
We will fix it in the next version of UniDirect.
Look forward to the announcements on our site.

aducom
Posts: 5
Joined: Tue 07 Nov 2006 13:24

Post by aducom » Thu 09 Nov 2006 10:45

I know, but as a potential customer I can ask these questions? Ok, I have removed the evaluation edition from my systems. Be advised that you need to fix some things here too, since it corrupted my Visual Studio helpfile system and had to reinstall VS fully to solve.

I'll look to other solutions, please remove my account.

Best regards,
albert

Alexey
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Post by Alexey » Thu 09 Nov 2006 10:56

Oh, i thought you asked this because you supposed this is the root cause of the problem. (By the way, the problem is fixed and the new build is available.)
What was the problem with the help? Probably you installed UniDirect .NET having Microsoft help collection opened.
If you still need any information about the licensing, let me know.

Post Reply