dbConnect Magento WAN connection fails

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Cloud Applications
Post Reply
robinhood1995
Posts: 5
Joined: Mon 23 May 2016 14:28

dbConnect Magento WAN connection fails

Post by robinhood1995 » Mon 23 May 2016 14:45

Hi,

I downloaded the magento connection for VS and I am using 2010 & 2015. I installed to try it out. I tried to follow the instructions to connect to my site with is not local to me.

I replace the domain name.

If I tried the connection my domain being https://www.domainname.com/store I get the following error:
---------------------------
Microsoft Visual Studio
---------------------------
Error accessing web service.
---------------------------
OK
---------------------------

I currently have a webservice setup that connections to my site fine and I am able to retrieve data.
For my web service I use https://wwwdomainname.com/store/api/v2_soap/?wsdl with my user and API key.

Thanks
Steve

Pinturiccio
Devart Team
Posts: 2420
Joined: Wed 02 Nov 2011 09:44

Re: dbConnect Magento WAN connection fails

Post by Pinturiccio » Wed 25 May 2016 12:09

Try using domain parameter without https://www. For example, try values like the following for the domain parameter:
- domainname.com
- www.domainname.com
- domainname.com/store
- www.domainname.com/store

Does one of these options work for you? If yes, which one does?

robinhood1995
Posts: 5
Joined: Mon 23 May 2016 14:28

Re: dbConnect Magento WAN connection fails

Post by robinhood1995 » Mon 30 May 2016 15:08

Thanks for the reply,

The ones without the store do not work and the others give a different error:
---------------------------
Microsoft Visual Studio
---------------------------
Error accessing web service. Invalid XML
---------------------------
OK
---------------------------

Pinturiccio
Devart Team
Posts: 2420
Joined: Wed 02 Nov 2011 09:44

Re: dbConnect Magento WAN connection fails

Post by Pinturiccio » Wed 01 Jun 2016 12:13

robinhood1995 wrote:I currently have a webservice setup that connections to my site fine and I am able to retrieve data.
For my web service I use https://wwwdomainname.com/store/api/v2_soap/?wsdl with my user and API key.
You are saying that you use the https://wwwdomainname.com/store/api/v2_soap/?wsdl. Is wwwdomainname.com a misprint, and there should be a dot after www, or this is the name of your domain? If this is the domain name, try using wwwdomainname.com instead of domainname.com:
- wwwdomainname.com
- wwwdomainname.com/store

robinhood1995
Posts: 5
Joined: Mon 23 May 2016 14:28

Re: dbConnect Magento WAN connection fails

Post by robinhood1995 » Sun 10 Jul 2016 21:50

Yes sorry the dot was missing after the www

https://www.domainname.com/store/api/v2_soap/?wsdl

The domainname is a foobar name that is not my real site.

I have tried without the www. and also without the https://www. and same issue.

Thanks
Steve

Pinturiccio
Devart Team
Posts: 2420
Joined: Wed 02 Nov 2011 09:44

Re: dbConnect Magento WAN connection fails

Post by Pinturiccio » Thu 14 Jul 2016 08:37

robinhood1995 wrote:For my web service I use https://wwwdomainname.com/store/api/v2_soap/?wsdl
Try using https://www.domainname.com/store/ or https://www.domainname.com/ value for the domain parameter.

You can also use Fiddler to find out to which URL your web service sends requests and use this URL as the domain parameter in MagentoConnection.

robinhood1995
Posts: 5
Joined: Mon 23 May 2016 14:28

Re: dbConnect Magento WAN connection fails

Post by robinhood1995 » Sat 17 Dec 2016 21:53

Hi Pinturiccio

If you look above I had tried that and it was not working.

Also is there a way to get a license extensions to keep trying it as I had another project come up and had to put this one aside.

Thanks

Shalex
Site Admin
Posts: 9103
Joined: Thu 14 Aug 2008 12:44

Re: dbConnect Magento WAN connection fails

Post by Shalex » Mon 19 Dec 2016 15:27

We have answered you via email.

robinhood1995
Posts: 5
Joined: Mon 23 May 2016 14:28

Re: dbConnect Magento WAN connection fails

Post by robinhood1995 » Tue 03 Jan 2017 04:24

Hi,

I have tried all I can think of and I cannot get the addin to connect to my site which is on the same network as me.

I get the following error ding this:
Error accessing web service. Procedure 'login' not present
This is using this domain https://www.hammerdownrange.com/store
and API and KEY

The other error is if I use this
x.x.x.x/databasename
The 'link' start tag on line 17 position 88 does not match the end tag of 'head'. Line 19, position 3.
and API and KEY

I would really try to try this out to reduce the entity structure of the sql selects or updates to the magento database.

thanks


Post Reply