Assertion failure with PgDAC 5.1.4

Discussion of open issues, suggestions and bugs regarding PgDAC (PostgreSQL Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
mfahs
Posts: 2
Joined: Mon 22 Jan 2018 12:15

Assertion failure with PgDAC 5.1.4

Post by mfahs » Mon 22 Jan 2018 12:40

Hello!
with version 5.1.4 (from 18.1.2018) I am getting the following assertion error if I activate a PgTable:

Error: Assertion failure (D:\Projects\Delphi\Dac\PostgreSql\Source\PgClasses.pas, line 7642)

With version 5.1.3 everything works fine, so I go back to the old version with all my DAC-products...
Could you help?

Thanks,
Martin

azyk
Devart Team
Posts: 1078
Joined: Fri 11 Apr 2014 11:47
Location: Alpha Centauri A

Re: Assertion failure with PgDAC 5.1.4

Post by azyk » Tue 23 Jan 2018 13:26

Thank you for the information. We reproduced the specified Assert and fixed it. This fix will be included in the next PgDAC build. If you want to get this fix before the official release, please write to the contact form at our website: https://www.devart.com/company/contactform.html and specify:
- the RAD Studio version you are using
- the mailbox where a night build with this fix could be sent

mfahs
Posts: 2
Joined: Mon 22 Jan 2018 12:15

Re: Assertion failure with PgDAC 5.1.4

Post by mfahs » Tue 23 Jan 2018 15:44

Thank you for your support! Unfortunately it's not possible for me to reach the site https://www.devart.com/company/contactform.html because my account doesn't allow me login in ("Invalid username or password"). And the "forgot password" function even does not work - I've tried it for 10 times... I could register a new account with my mailadress (sure!), but it doesn't work also. So It's not possible for me to sign in.... what could I do?

Regards
Martin

azyk
Devart Team
Posts: 1078
Joined: Fri 11 Apr 2014 11:47
Location: Alpha Centauri A

Re: Assertion failure with PgDAC 5.1.4

Post by azyk » Wed 24 Jan 2018 08:46

We are currently investigating possible issue causes with your login.

Please send to my mailbox andreyz*devart*com :
- the RAD Studio version you are using
- the mailbox where a night build with this fix could be sent

Post Reply