INSTALL PgDac 6.13 on Windows Lazarus 2.0.10

Discussion of open issues, suggestions and bugs regarding PgDAC (PostgreSQL Data Access Components) for Delphi, C++Builder, Lazarus (and FPC)
Post Reply
evertof
Posts: 2
Joined: Thu 17 Sep 2020 11:54

INSTALL PgDac 6.13 on Windows Lazarus 2.0.10

Post by evertof » Thu 17 Sep 2020 12:08

I'm trying install PGDac 6.13 on Windows Lazarus 2.0.10, and i have this error:

"Obj := TPersistent(NativeInt(GetPropValue(Control, string(PropList.Name))));"

Error: Illegal type conversion: "Variant" to "NativeInt"

what i do?

oleg0k
Devart Team
Posts: 98
Joined: Wed 11 Mar 2020 08:28

Re: INSTALL PgDac 6.13 on Windows Lazarus 2.0.10

Post by oleg0k » Mon 21 Sep 2020 14:16

Hello,
Lazarus 2.0.10 and FPC 3.2.0 are supported starting with version 6.3.1. If you're going to use an earlier version of PgDAC, you also need to use an earlier version of Lazarus

wbr, Oleg
Devart Team

evertof
Posts: 2
Joined: Thu 17 Sep 2020 11:54

Re: INSTALL PgDac 6.13 on Windows Lazarus 2.0.10

Post by evertof » Fri 25 Sep 2020 19:30

thanks, its worked

Post Reply