Error updating version Entity Developer - Does not allow to add SP, mix Entity Core

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
alfredo.avmb
Posts: 10
Joined: Wed 23 Aug 2017 04:07

Error updating version Entity Developer - Does not allow to add SP, mix Entity Core

Post by alfredo.avmb » Thu 26 Jul 2018 23:43

Error updating version Entity Developer - Does not allow to add SP, mix Entity Core

Good afternoon, make an update of the version of entity developers and now the stored procedures do not work:

I currently work with Windowsforms, C #, SQL Server Express 2016 SP1, .NET FRAMEWORK 4.5.2 and entity framewor 6.2 this update as well.

You are using the version of Entity developers Version 6.2.414 (11-Jan-2018) and migrate to version v6.3.543 (19 Jul 2018).

Now when I compile my project in VS2017 with c # send me this message:

Severity Code Description Project File Line Status suppressed
Error CS1503 Argument 2: Unable to convert from 'System.Data.Objects.ObjectParameter' to 'System.Data.Entity.Core.Objects.ObjectParameter'
siafentitymodel E: \ GIT \ siaf \ siafentitymodel \ Context \ AppEntities.SIAFEntities.Generated .cs 815 Active


I do not use anything from NET. CORE, what problems do I have or what should I do to solve this message, I attach images.

regards

Image

[img]E:\Error - Entity Developers - 00.png[/img]

Shalex
Site Admin
Posts: 8474
Joined: Thu 14 Aug 2008 12:44

Re: Error updating version Entity Developer - Does not allow to add SP, mix Entity Core

Post by Shalex » Fri 27 Jul 2018 13:23

alfredo.avmb wrote:
Thu 26 Jul 2018 23:43
Error CS1503 Argument 2: Unable to convert from 'System.Data.Objects.ObjectParameter' to 'System.Data.Entity.Core.Objects.ObjectParameter'
System.Data.Objects.ObjectParameter is used by EF4.
System.Data.Entity.Core.Objects.ObjectParameter is used by EF6.

Looks like there is a mix of EF versions in your project. Here is a difference between EF6 and the previous EF versions: https://msdn.microsoft.com/en-us/librar ... .113).aspx.

Please check:

1) open your *.edml, double click diagram surface to open Model Settings and make sure that your Entity Framework version property is set to Entity Framework 6. Save your model to regenerate the code

2) does your application config file include the following entries?

Code: Select all

<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <configSections>
    <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=6.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false"/>
  </configSections>
  <connectionStrings>
    <add name="YourConnectionString" connectionString="... />
  </connectionStrings>
  <startup>
    <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.5.2"/>
  </startup>
  <entityFramework>
    <providers>
      <provider invariantName="System.Data.SqlClient" type="System.Data.Entity.SqlServer.SqlProviderServices, EntityFramework.SqlServer"/>
    </providers>
  </entityFramework>
</configuration>
If this doesn't help, send us a test project for reproducing the issue.

alfredo.avmb
Posts: 10
Joined: Wed 23 Aug 2017 04:07

Re: Error updating version Entity Developer - Does not allow to add SP, mix Entity Core

Post by alfredo.avmb » Fri 27 Jul 2018 15:43

Good morning, as I said, I have entity framework 6.2 to update it, tell me or understand that this version works for CORE, I recommend downloading the version to 4x. to continue working normal.

Another question, once I have corrected this EF problem, I can update to the latest version of Entity Developer that they have or these versions do not work with the ones I have.

I await your comments. And I'm reviewing.

regards

Shalex
Site Admin
Posts: 8474
Joined: Thu 14 Aug 2008 12:44

Re: Error updating version Entity Developer - Does not allow to add SP, mix Entity Core

Post by Shalex » Mon 30 Jul 2018 12:38

The list of Entity Framework versions supported by Entity Developer is available at https://www.devart.com/entitydeveloper/ ... ility.html.

If the issue with upgrade persists, please send us a test project and specify the steps we should follow for reproducing.

Post Reply