EntityDeveloper for NHibernate problem with licence

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
lavoyech
Posts: 3
Joined: Wed 24 Jan 2018 15:54

EntityDeveloper for NHibernate problem with licence

Post by lavoyech » Wed 24 Jan 2018 16:36

Hello,

I'm working with Entity Developer for NHibernate and Devart dotConnect for PostgreSQL.

I have normally a licence expiring in September 07, 2018. (I could give you the ref)

But i'm not able to regenerate my model and i get the error

"Sorry, your trial period has expired. To order registered version please visit Devart site at www.devart.com/dotconnect/postgresql/ordering.html"

So i wonder if my licence for Entity Developer for NHibernate is differnte from dotconnect for PostgreSQL? do i need two licences?

Or how can i set it?

Then i have another request. In Tools/Options, for NHibernate we can defined "NHibernate assemblies folder". What is the use?

I will have to upgrade the NHibernate dll i was using in my .NET project from 3.3.3.4001 to 5.0.3. Do i need to set it in the Tools/Options in Entity developer?

Best regards,
Christophe.

Shalex
Site Admin
Posts: 8240
Joined: Thu 14 Aug 2008 12:44

Re: EntityDeveloper for NHibernate problem with licence

Post by Shalex » Thu 25 Jan 2018 19:04

lavoyech wrote:So i wonder if my licence for Entity Developer for NHibernate is differnte from dotconnect for PostgreSQL? do i need two licences?
1. That is correct, you need both products:
* Entity Developer for NHibernate is an ORM designer and code generation tool (doesn't include any predefined provider).
* dotConnect for PostgreSQL Professional includes runtime support for NHibernate.
lavoyech wrote:Then i have another request. In Tools/Options, for NHibernate we can defined "NHibernate assemblies folder". What is the use?
2. Specify the path to NHibernate assemblies to execute queries in design time with Entity Developer. Refer to https://www.devart.com/entitydeveloper/ ... eloper.chm (download, right click and press Unblock) > Basic Workflows > Working with Queries and Data > Configuring Entity Developer for Executing Queries.
lavoyech wrote:I will have to upgrade the NHibernate dll i was using in my .NET project from 3.3.3.4001 to 5.0.3. Do i need to set it in the Tools/Options in Entity developer?
3. Please specify the name of the option your question is about. Have you encountered any issues after upgrading your project from 3.3.3.4001 to 5.0.3?

lavoyech
Posts: 3
Joined: Wed 24 Jan 2018 15:54

Re: EntityDeveloper for NHibernate problem with licence

Post by lavoyech » Fri 26 Jan 2018 09:25

Hello,

Thanks for your answer.

In fact my problem seems to come from an update of dotconnect PostrgreSQL (7.1 Trial) which replaced the ole version i was using. Ans as the rial period is ended i get the error.

I ask to my support to reinstall the the version i was usind. Do you think it will resolve my problem?

Best regards,
Christophe.

Shalex
Site Admin
Posts: 8240
Joined: Thu 14 Aug 2008 12:44

Re: EntityDeveloper for NHibernate problem with licence

Post by Shalex » Fri 26 Jan 2018 11:42

lavoyech wrote:In fact my problem seems to come from an update of dotconnect PostrgreSQL (7.1 Trial) which replaced the ole version i was using. Ans as the rial period is ended i get the error.
You should install the licensed version of dotConnect for PostgreSQL Professional. Please download it from Cusomer Portal (URL, account name, and password should be provided by our Sales department after the purchase of the product).

Post Reply