When save don´t generate code in VS2017

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
txemam@workflobm.com
Posts: 3
Joined: Mon 22 Jan 2018 20:16

When save don´t generate code in VS2017

Post by txemam@workflobm.com » Mon 22 Jan 2018 20:27

Hi

I have one rare problem with Entity developer
I configure the settings for output dirs, etc... and when save in the visual studio 2017 add-in don't generate the code what i have been selected.
The output options are file per class and generate partial class
The Template for generation is for EF Core only

If i do the same with the app runs fine
My version of vs 2017 is enterprise and it have spanish localization

Shalex
Site Admin
Posts: 8248
Joined: Thu 14 Aug 2008 12:44

Re: When save don´t generate code in VS2017

Post by Shalex » Tue 23 Jan 2018 19:12

1. Are you using the newest (6.2.414) build of Entity Developer?

2. Open your *.efml model in VS2017, navigate to Tools > Entity Developer > Model Explorer > the Templates node, select EF Core, press F4 (Properties) and make sure that:
a) Type = Predefined
b) Enabled = True

3. Does the issue persist with a newly created VS2017 project?

txemam@workflobm.com
Posts: 3
Joined: Mon 22 Jan 2018 20:16

Re: When save don´t generate code in VS2017

Post by txemam@workflobm.com » Wed 24 Jan 2018 07:44

hi Shalex
Thank's for you response

1 yes, but my version is express and i have only 3 entities in the diagram
2 i have setted both options in EFCore template and only use this
3 the project is newer

Thank's

Shalex
Site Admin
Posts: 8248
Joined: Thu 14 Aug 2008 12:44

Re: When save don´t generate code in VS2017

Post by Shalex » Wed 24 Jan 2018 09:00

Is the problem with regenerating code by Entity Developer embedded into VS2017 constant OR intermittent?

If it is constant, please upload a small test project for reproducing to ftp://ftp.devart.com (credentials: anonymous / yourEmail) or some other file exchange server.

txemam@workflobm.com
Posts: 3
Joined: Mon 22 Jan 2018 20:16

Re: When save don´t generate code in VS2017

Post by txemam@workflobm.com » Wed 24 Jan 2018 15:14

Hi Again Shalex
The problem is constant
I upload the sample for you to ftp

Thanks

Shalex
Site Admin
Posts: 8248
Joined: Thu 14 Aug 2008 12:44

Re: When save don´t generate code in VS2017

Post by Shalex » Mon 29 Jan 2018 19:29

Thank you for your test project. We will investigate the issue and notify you about the result.

Shalex
Site Admin
Posts: 8248
Joined: Thu 14 Aug 2008 12:44

Re: When save don´t generate code in VS2017

Post by Shalex » Thu 15 Feb 2018 17:39

The bug with applying the DevartEFCoreGenerator custom tool in Visual Basic .NET Core projects is fixed: viewtopic.php?f=32&t=36594.

Post Reply