Call an SP and it does not appear in the data source

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
alfredo.avmb
Posts: 10
Joined: Wed 23 Aug 2017 04:07

Call an SP and it does not appear in the data source

Post by alfredo.avmb » Tue 05 Dec 2017 16:17

Good morning, I have a series of SP that are in my BD, I add them to the model, when I want to recover them in a bindingsource, this month does not present them, only the tables.

What is the correct process or what is my error that does not present them or how should I call them, are SP that present a series of records filtered by a code.

regards

Shalex
Site Admin
Posts: 8246
Joined: Thu 14 Aug 2008 12:44

Re: Call an SP and it does not appear in the data source

Post by Shalex » Thu 07 Dec 2017 20:36

We have received your email and are processing your request. We will contact you as soon as possible.

Shalex
Site Admin
Posts: 8246
Joined: Thu 14 Aug 2008 12:44

Re: Call an SP and it does not appear in the data source

Post by Shalex » Mon 11 Dec 2017 19:36

We have asked for the additional information by email.

alfredo.avmb
Posts: 10
Joined: Wed 23 Aug 2017 04:07

Re: Call an SP and it does not appear in the data source

Post by alfredo.avmb » Mon 11 Dec 2017 20:11

263/5000
Good afternoon, I resolved reading the help, although in my opinion the screen is outdated or maybe I did not understand it well, but I managed to add the stored procedures to the data model,

Following this reading link, Working with Complex Types

regards

Shalex
Site Admin
Posts: 8246
Joined: Thu 14 Aug 2008 12:44

Re: Call an SP and it does not appear in the data source

Post by Shalex » Tue 12 Dec 2017 08:07

alfredo.avmb wrote:but I managed to add the stored procedures to the data model,
1. Glad to hear that the issue is solved.
alfredo.avmb wrote:I resolved reading the help, although in my opinion the screen is outdated or maybe I did not understand it well
2. EntityDeveloper.chm (download, right click > Properties > Unblock) > ORM Support > Entity Framework > Concepts > Working with Complex Types > the "Returning Complex Type from Method" section: we have checked a screenshot, it is up-to-date. To run Method Editor, right click method in the Methods node in Model Explorer > Edit. Could you please send us a screenshot of your Method Editor which is different to the one described in documentation?

Post Reply