Show schema in Model Explorer and Diagram?

Discussion of open issues, suggestions and bugs regarding Entity Developer - ORM modeling and code generation tool
Post Reply
RobertK
Posts: 56
Joined: Thu 02 Mar 2017 05:44

Show schema in Model Explorer and Diagram?

Post by RobertK » Wed 22 Mar 2017 03:43

How do I display schema in Model Explorer and Diagram?
(its confusing to not display the schema)

Shalex
Site Admin
Posts: 8247
Joined: Thu 14 Aug 2008 12:44

Re: Show schema in Model Explorer and Diagram?

Post by Shalex » Wed 22 Mar 2017 11:14

You are working with Devart EF Core Model (*.efml) and PostgreSQL Server, aren't you?

Please select entity on a diagram or in Model Explorer, press F4 (Properties). There is the Schema property.

If you want to access objects from different schemas in Database Explorer, press the "Show All Objects" button in it.

Is that what you mean?

RobertK
Posts: 56
Joined: Thu 02 Mar 2017 05:44

Re: Show schema in Model Explorer and Diagram?

Post by RobertK » Wed 22 Mar 2017 13:44

Shalex wrote:You are working with Devart EF Core Model (*.efml) and PostgreSQL Server, aren't you?
Yes that is correct.

What I mean is I would like to toggle on/off to display the schema name next to the class model in both the "Model Explorer" and in the Diagram.

As you can see here you can not see the schema names!
Image

Shalex
Site Admin
Posts: 8247
Joined: Thu 14 Aug 2008 12:44

Re: Show schema in Model Explorer and Diagram?

Post by Shalex » Thu 23 Mar 2017 11:03

RobertK wrote:
Shalex wrote:You are working with Devart EF Core Model (*.efml) and PostgreSQL Server, aren't you?
Yes that is correct.
1. It is Devart NHibernate Model (*.hbml) set for talking to SQL Server via System.Data.SqlClient on your screenshot.
RobertK wrote:What I mean is I would like to toggle on/off to display the schema name next to the class model in both the "Model Explorer" and in the Diagram.
2. We recommend you to create several diagrams in your model (one diagram for each schema). There is no way to display schema name next to class name.

RobertK
Posts: 56
Joined: Thu 02 Mar 2017 05:44

Re: Show schema in Model Explorer and Diagram?

Post by RobertK » Thu 23 Mar 2017 14:54

Shalex wrote:2. We recommend you to create several diagrams in your model (one diagram for each schema). There is no way to display schema name next to class name.
Is this a feature you would consider adding to your backlog? (many other modeller lets you toggle on/off the schema)

Shalex
Site Admin
Posts: 8247
Joined: Thu 14 Aug 2008 12:44

Re: Show schema in Model Explorer and Diagram?

Post by Shalex » Fri 24 Mar 2017 18:09

Please submit your suggestion at https://devart.uservoice.com/forums/386 ... -developer.

JIC: there is the "Add schema as prefix" option on the "Set up naming rules" step of Create Model Wizard. Or you can set the "Add schema as prefix" option in Model Settings > Synchronization > Model Naming (it will be applied for the newly added entities).

Post Reply